9

I have Win 7 Professional 32 bit SP 1 and I received a notification about the available important security update KB3185330 today, but it fails to install.

I tried to install it through the Windows Updater, it downloaded it, initialized the installation and requested a reboot, which I did. During shutdown, it starts preparing the update and during the next boot, it continues until around 80-100%. Then it fails, rolls back the upgrade and reboots again. After that, the update is still listed for installation and shows as failed attempt in the update log with error code 80004005.

Downloading the update manually from the link above and executing it leads to the same result.

As it has been mentioned a few times, I am dual-booting with Ubuntu 16.04, using GRUB boot manager.

I already tried downloading and running this Windows Update Diagnostics file, it said to have found some problems and fixed them, but rebooting and reattempting the update leads to the same result.

What is wrong with my system? How can I install this security update?
What error logs do you need to troubleshoot the issue and where can I find them?

  • Comments are not for extended discussion; this conversation has been moved to chat. – Journeyman Geek Oct 15 '16 at 3:30
  • @JourneymanGeek The discussion was over, you could have left it there... – Byte Commander Oct 15 '16 at 10:45
  • If anyone wants to read the old discussion, they can pop into the chat page. Policy here is that comments are transient. It was that or deleting them all, as far as I am concerned. – Journeyman Geek Oct 15 '16 at 11:17
7

In the CBS logs of @PeterdeRivaz the command

"C:\Windows\bfsvc.exe" C:\Windows\boot /nofonts"

fails with 0x0000007b (ERROR_INVALID_NAME - The filename, directory name, or volume label syntax is incorrect) when updating the Bootloader (Microsoft-Windows-BootEnvironment).

This could be caused by an installed GRUB bootloader. Therefore remove GRUB, so that you only use the Windows bootloader, install the update kb3185330 and then reinstall GRUB to be able to boot your Linux systems again.

This is a known issue for years, because Microsoft never cares and tests their updates with installed GRUB bootloader, they think everyone is only using Windows and nothing else.

As reported in the comments, this solution worked for @ByteCommander as well.

  • 1
    This worked for me. However, I strongly recommend physically disconnecting any hard drives other than your windows drive before trying to use the Windows startup repair utility (otherwise you see error messages such as "operating system is missing" and "no filesystem detected" and "bootrec /fixboot" failure) – Peter de Rivaz Oct 15 '16 at 19:35
  • @PeterdeRivaz Yup, been there. But I have both OS on the same disk. Finally I was able to do it manually with BootICE from hiren's bootcd though.Win 7 installation CD was useless. – Byte Commander Oct 18 '16 at 17:28

protected by Community Oct 14 '16 at 12:08

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Not the answer you're looking for? Browse other questions tagged or ask your own question.