2

I am forever frustrated with how cut and paste works in LibreOffice.

For example, I find that phone numbers are treated as numeric and leading zeros go missing, or plain text gets pasted with font formatting, or I get a popup giving me more options.

I know there are different "kinds" of Paste operation, and that you can choose which to bind to Ctrl+V via the Customize menu, but I've explored those options and they still don't do what I want.

The behaviour which is almost always what I want is achieved by selecting the cell, clicking into the formula bar, and then doing Ctrl+V there.

None of the existing paste options seems to correspond to "paste into formula bar" (all strings are literals including numbers, no formatting or hyperlinks, no popups). Can I bind this behaviour to a keypress some other way?

0

I sympathise with your frustration.

What I do in this situation is "Paste special" (Shift-Cmd-V on Mac OS):

  1. Copy the text from another location.
  2. Click in the destination cell in LibreOffice-Calc
  3. Edit... Paste special... (Shift-Cmd-V on Mac OS X). A ''Paste Special'' dialogue appears, with various format options, including "Unformatted text".
  4. Type 'u'. The "Unformatted text" is selected.
  5. Press Enter. The dialogue box disappears, and the text is selected.
  6. Press Tab, or an arrow key, to move the selection out of the destination cell. Do not press Space, or Enter. That might cause Calc to turn text that spells out a URL into a hyperlink.

You said "no popups". This gives a popup. However, it is dismissed with just a keypress of "u" followed by enter. I find I have become quite efficient at typing "Shift-Cmd-V", "U", "Enter" quickly.

This works for me for telephone numbers formatted in the North American way, with multiple internal hyphens, or with parentheses "()", e.g. "604-555-1212" or "(604) 555-1212". It preserves leading zeros in formatted phone numbers, e.g. "03-1111-2222".

Strings of digits with leading zeros are a tougher problem. What I do here is prepare the destination cell with Text formatting:

  • Select the destination cell (or range of cells).
  • Format... Cells.... The Format Cells dialogue appears.
  • Click the Numbers tab. Lists for Category and Format appear.
  • Under Category, select Text. In the Format list, then entry @ appears.
  • Click the OK Button. The Format Cells dialogue disappears.

Now, when you paste "Unformatted text" into those cells with the "Text" format, leading zeroes are preserved.

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.