7

On my raspberry pi I am using bash with powerline and also vim with powerline.

If I connect the Pi to an external display everything looks fine but when I connect via MobaXterm or Cygwin ssh the arrows do not get displayed.

I believe this is a problem with the fonts? Has anybody got this working?

3 Answers 3

11

Because this is the only result on Google for this particular problem, I thought I'd add my solution.

  1. You need to install a patched font in windows. You can find versions of the popular coding fonts here, as well as others using a Google search. These fonts add the Powerline symbols in the Unicode Private Use area, but otherwise, the fonts are the same.

  2. Restart MobaXTerm so the newly installed fonts appear. Under Settings > Terminal change the font to whichever patched font you installed.

  3. MobaXTerm saves the font setting independently in any saved sessions, so you will need to edit each one of those as well. Right-click > Edit Session > Terminal Settings > Font.

  4. Once again, MobaXTerm needs to be restarted for your changes to appear.

3
  • 4
    Matt is correct, but note that MobaXTerm doesn't seem to support every font. In Putty, you can open Putty Configuration > Window > Appearance > Allow selection of variable-pitch fonts. But MobaXTerm, as of September 2018, doesn't allow "variable-pitch" fonts, so your options in MobaXTerm are limited to certain Monospaced(?)/fixed-width fonts like DejaVuSansMono github.com/powerline/fonts/tree/master/DejaVuSansMono and Source-Code-Pro (github.com/adobe-fonts/source-code-pro/releases/tag/…) which don't support all the cool icons in Nerd-Fonts. Commented Sep 12, 2018 at 13:35
  • 1
    This worked for me, for those wondering, how to install powerline on windows, please follow this link: medium.com/@slmeng/…
    – kzs
    Commented Mar 15, 2019 at 13:44
  • "MobaXTerm saves the font setting independently in any saved sessions" - thanks for this tip.
    – Michael D
    Commented Sep 30, 2021 at 7:14
2

I had the same issue and reached out to support and they directed me to use this font, which appears to work . . .

https://github.com/halocaridina/.dotfiles_thinkpad_x230/blob/master/Xresources/.local/share/fonts/PragmataPro/PragmataPro%20for%20Powerline.ttf)

0

For me, It works for me in Windows Terminal as well as in MobaXterm. Tried below given font to fix icon missing issue.

MesloLGS NF

======= OR ==========

RobotoMono NF

======= OR ==========

Delugia Nerd Font

====================

Download link for Font:

  1. https://github.com/romkatv/dotfiles-public/blob/master/.local/share/fonts/NerdFonts/MesloLGS%20NF%20Regular.ttf
  2. https://github.com/google/fonts/raw/master/apache/robotomono/RobotoMono%5Bwght%5D.ttf
  3. https://github.com/adam7/delugia-code/releases/download/v2009.14/Delugia.Nerd.Font.Complete.ttf

Hope it Helps!!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .