Some time ago, some of my games were not working because of this error called 0xc000007b. After following a bad tutorial, my computer's System32 folder ended up with some files mixed up (I checked with the Dependency Walker on some of the games that were not working) and now most of my games that run on 32bit don't work. I tried using DLL-FIXER to correct the files in the folder but it didn't work, and the error persisted. How can I fix it?

The computer is an ASUS ROG computer with x64 architecture running Windows 10, NVIDIA video card, and i7 processors (if that can help). I also have the Visual C++ Redistributables (2005,08,10, and 15, if I remember correctly) installed.

Examples of games that are not working are: Borderlands 2, Mount and Blade: Warband, Elite: Dangerous, and some more.

There was, also, and strange error when I added the conflicting .DLL files to Mount And Blade: Warband's folder (following the instructions from Dependency Walker). The game opened properly, but crashed and outputted and error message about not being able to open postfx, and asking to install the latest version of DirectX, even though it is already installed.

Edit: The main problem seems to be DirectX 9, because most of it's libraries (like d3dx9_43.dll, for instance) have been bugging the games (I checked this with Dependency Walker), and attempting to install is either yields a "successfully installed" message with no results or an error message. The log file looks like this: https://www.dropbox.com/s/8gthptp72uohxg5/DirectX.log?dl=0


1 Answer 1


First off, unless you know what you are doing, one should never modify Windows system files or folders. In addition to that, programs that say they will fix your DLLs are garbage at best and highly destructive at worst. Do not use them.

I would open an administrative command prompt with Win+X and type sfc /scannow. This will run the System File Checked and hopefully repair any damage done.

  • I don't think this worked. The sfc command completed its verification and outputted the following: Windows Resource Protection did not find any integrity violations. and the error still persists when opening the game mentioned in my question.
    – Carmo
    Oct 13, 2016 at 14:18

Not the answer you're looking for? Browse other questions tagged .