2

As far as I know Nautilus is default file manager for GNOME.

Recently I updated it (this is what I think). What I did was:

apt-get install nautilus

After few minutes download was complete, after a restart when I tried to open Files it was not working. The file explorer will not open how hard I try.

Then I tried to remove it with the following command:

dpkg --list #(to confirm the file name)
apt-get remove nautilus/nautilus-data

But there was an error:

apt-get remove nautilus
Reading package lists... Done
Building dependency tree
Reading state information...
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
 gsettings-desktop-schemas : Breaks: mutter (< 3.19.92) but 3.18.2-1 is to be installed
 libgnome-desktop-3-12 : Breaks: mutter (< 3.21.2) but 3.18.2-1 is to be installed
E: Error, pkgProblemResolver::Resolve generated breaks, this may be caused by held packages.

Since I cannot remove it I have only one option i.e. to switch to some other file manager but I do not want to switch.

Any kind of help would be appreciated.

EDIT(updated):
when I type nautilus in terminal it gives following error:

nautilus: symbol lookup error: /usr/lib/x86_64-linux-gnu/libgnome-autoar-0.so.0: undefined symbol: archive_entry_is_encrypted

I think maybe it is loading wrong libraries.
And I also tried

apt-get install --reinstall nautilus

Error is still same

3
  • This may help: askubuntu.com/questions/124845/… Also, what does it say when you just enter nautilus in the terminal in your current state? – sigalor Oct 15 '16 at 11:11
  • it gives error as follow: nautilus: symbol lookup error: /usr/lib/x86_64-linux-gnu/libgnome-autoar-0.so.0: undefined symbol: archive_entry_is_encrypted – Imnoob Oct 16 '16 at 11:47
  • @sigalor i was already trying to remove it but the problem it while I try to remove it gives some error as posted above. – Imnoob Oct 16 '16 at 11:53
1

There maybe some solution to this,but I am only writing how I fixed it.
Run:

apt-get update && apt-get upgrade

Due to any reason if process haults type:

apt-get update && apt-get upgrade --fix-missing

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.