12

I have a laptop, which was running Windows 8.1 x64 without any problems. Now with Windows 10 x64 installed, Task Manager constantly shows unusual CPU usage by "System" and "System interrupts". To solve this, I already tried the following, without success:

  • Disabling and uninstalling all non-essential drivers.
  • Installing newer drivers than the ones that were automagically installed (if available).
  • Disabling/enabling fast boot option.
  • Disabling all of the non-essential services.
  • Sysprep.
  • Resetting BIOS to defaults and various combinations of settings.
  • Flashing BIOS to the latest available version.
  • Clean install from the same media that I use for other PCs.
  • Installing all of the updates offered in Windows Update to this day.
  • Windows Performance Recorder / Analyzer.

I'm not very familiar with Windows Performance Analyzer, so I'm hoping someone here can point me in the right direction - what exactly should I look for, to figure out which device/driver is the culprit. Or, if there's any other approach to figuring out this problem?

For the brave souls, here's my trace file from WPRUI and a screenshot of the problem:

Task Manager view

1
  • I fixed this very problem (system process firing up after exactly 4 minutes of the pc being idle) by disabling "scheduled optimization" under defrag, which is enabled by default, however i'm not 100% sure about this due to several windows 10 updates being pushed at the time of the test. Anybody can check to know for sure? Nov 4, 2018 at 20:08

3 Answers 3

6

Thank you so much, magicandre1981, for taking a look. By pure luck I stumbled upon a solution. In this case, it was to install Intel Rapid storage Technology (RST). As I understand, it replaces the SATA controller driver, but I don't think that a different driver alone helped, as I tried various drivers before. The strange CPU usage doesn't go down until the little icon in the screenshot below shows up in system tray. Doesn't matter whether the "RST Service" is running or not, as soon as the tray application launches, everything starts behaving normally.

Intel Rapid Storage Technology tray icon

For anyone having the same problem, the exact laptop model in question was "Samsung NP700Z7C-S01US", storage controller hardware ID "VEN_8086&DEV_1E03" and version of Intel RST that helped is "12.9.0.1001" (newer versions throw error during installation).

10
  • have you tried to go back to the standard MS storage driver? Oct 17, 2016 at 7:24
  • With MS driver and Intel tray application running the problem came back. It seems it's a combination of Intel driver + whatever magic their application is doing.
    – Brane
    Oct 19, 2016 at 9:01
  • ok, I'll remember this solution for other users Oct 19, 2016 at 9:27
  • 1
    My case for Samsung Chronos 7 was the 'Realtek High Definition Audio' driver that was the case. Disable that device in Device handler remove the CPU usage for acpi.sys. Uninstalled and removed the driver at same time, then installed it again from realteks homepage (used version R2.81). Jul 18, 2017 at 15:19
  • 1
    Samsung Chronos 7 user here. Installing Intel Rapid Storage Technology did the trick. I've spent days debugging this and had started messing around with full memory dumps and WinDbg. Thanks a lot!
    – Martin
    Aug 6, 2017 at 16:13
6

The DPC usage comes from the ACPI.sys driver:

Line #, DPC/ISR, Module, Stack, Count, Process, Weight (in view) (ms), TimeStamp (s), % Weight
6, , ,   |    |- ACPI.sys!ACPIWorkerThread, 40246, , 39.992,941063, , 4,13
7, , ,   |    |    ACPI.sys!RestartCtxtPassive, 40246, , 39.992,941063, , 4,13
8, , ,   |    |    ACPI.sys!InsertReadyQueue, 40246, , 39.992,941063, , 4,13
9, , ,   |    |    ACPI.sys!RunContext, 40246, , 39.992,941063, , 4,13
10, , ,   |    |    ntoskrnl.exe!KeReleaseSpinLock, 40246, , 39.992,941063, , 4,13
11, , ,   |    |    ntoskrnl.exe!KiDpcInterrupt, 40246, , 39.992,941063, , 4,13
12, , ,   |    |    ntoskrnl.exe!KiDispatchInterruptContinue, 40246, , 39.992,941063, , 4,13
13, , ,   |    |    ntoskrnl.exe!KxRetireDpcList, 40246, , 39.992,941063, , 4,13
14, , ,   |    |    ntoskrnl.exe!KiRetireDpcList, 40246, , 39.992,941063, , 4,13
15, , ,   |    |    |- ntoskrnl.exe!KiExecuteAllDpcs, 40198, , 39.945,173325, , 4,13
16, , ,   |    |    |    |- ACPI.sys!ACPIInterruptDispatchEventDpc, 27565, , 27.408,930428, , 2,83
17, , ,   |    |    |    |    |- ACPI.sys!ACPIGpeEnableDisableEvents, 24525, , 24.384,921620, , 2,52
18, , ,   |    |    |    |    |    ACPI.sys!ACPIWriteGpeEnableRegister, 24525, , 24.384,921620, , 2,52
19, , ,   |    |    |    |    |    |- hal.dll!HalpAcpiPmRegisterWrite, 24421, , 24.281,015516, , 2,51
20, , ,   |    |    |    |    |    |    |- hal.dll!HalpAcpiPmRegisterWritePort, 24166, , 24.027,316013, , 2,48

this is extremely difficult to debug. In a sysinternals topic I listed some advices:

  • make sure the CPU doesn't overheat becasue of dust in the CPU fan
  • update or reflash the BIOS/UEFI
  • load default BIOS/UEFI settings
  • make sure the battery is not damaged
  • change jumper on HDD caddy (doesn't apply to you, you still us your optical drive and haven't replaced it)
  • disable some devices as adviced by this user
1
  • +1 for the HDD Caddy notice. Moving the jumper from left to the middle (not right) completely decreased ACPI.sys high CPU usage.
    – maliayas
    Oct 11, 2018 at 11:48
0

I just had exactly this (Win10 Pro x64) on a Dell XPS 15, it was so bad that most of the time I couldn't even get Task Manager to display any processes, it would just hang on a mostly blank window, touchpad was barely responsive, and sooner or later I would get a DPC_WATCHDOG_VIOLATION BSOD (presumably because a driver was getting stuck for too long) etc.

I tried a few things - disabling tons of Device Manager entries, updating or changing drivers etc - but nothing worked. I was nearly ready to just overwrite a prior backup image, but with nothing to lose this worked:

  • Device Manager -> View -> Devices by Connection
  • find some juicy root nodes (eg. PCI(e) stuff, USB 3.0 controllers, HD controllers) and nuke them, taking everything below with them. Don't necessarily delete their drivers if asked (unless desperate).
  • reboot.

Bingo, pretty much all my hardware was re-detected on next boot, and the problem went away. I can only assume that it wasn't so much a single rogue driver, as some corruption in my driver setup (or a specific driver's setup) generally.

At least this way you don't spend days trying to isolate the problem (I did : ).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .