5

I just downloaded and installed Lynx for Windows and It does not support HTTPS to browse most of the websites today, especially Wikipedia.

I download it from Invisible Island, I guess it's the official site for the application

I've also read that some users modify configuration files and build it with SSL enabled in Linux.

The Windows version doesn't offer such support configuration during the setup.

enter image description here

How can I enable SSL or add the HTTPS support to Lynx in Windows?

  • You would have to add HTTPS support to it. With that said since software recommendations are not on topic here at Superuser, its not possible for us, to make suggestions of alternatives. – Ramhound Oct 16 '16 at 1:47
  • How to add the HTTPS support to it? – user373230 Oct 16 '16 at 2:20
  • You would have to modify the source of the program – Ramhound Oct 16 '16 at 3:48
  • Use cygwin lynx – DavidPostill Oct 16 '16 at 10:20
1

How can I enable SSL or add the HTTPS support to Lynx in Windows?

Use the Cygwin version of lynx.

It has SSL already compiled in and can browse https pages.

$ lynx --version
Lynx Version 2.8.7rel.1 (05 Jul 2009)
libwww-FM 2.14, SSL-MM 1.4.1, OpenSSL 1.0.2h, ncurses 6.0.20160423(wide)
Built on cygwin Apr 10 2013 12:32:36

$ lynx https://superuser.com/questions

enter image description here

  • Sadly the page to download doesn't seem to function Internal Server Error – user373230 Oct 16 '16 at 15:48
  • 1
    @Chinggis6 Only the package search page is broken. Download and install cygwin from this page Installing and Updating Cygwin Packages. Make sure you select the lynx package when installing. – DavidPostill Oct 16 '16 at 16:50
  • 1
    Yeah, but I'd like to install just Lynx without having to install the whole Cygwin, but thanks I didn't know it is included in Cygwin, I'll try it through Cygwin now – user373230 Oct 16 '16 at 20:14
0

At Invisible Island, you can download "Latest built with curses (not color-style)" and it mostly works. It doesn't seem to have access to the correct certificate info so I had to set FORCE_SSL_PROMPT:YES in the .cfg file so I'm not prompted with errors. (Well, it shows you errors but you don't have to do anything about them.)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy