0

The list of WiFi connections in my list in Windows 7 is constantly changing as WiFi networks come and go. I cannot even connect to mine.

Meanwhile inSSIDer is showing my WiFi network with max signal pretty stable at ~57dBm as I sit just 3m (10ft) away from the router and there are no obstacles in between.

Could that still be a network adapter issue? Last time I saw it working with my old 802.11b/g router a couple of months ago, now I have a 802.11b/g/n one. WiFi adapter only supports 802.11a/b/g though.

  • Do you have so many networks in the vicinity that the list is too short? In that case, you could try setting up the connection manually. – Daniel B Oct 16 '16 at 14:51
  • Dainel B: thanks for your response - on my other PC where everything is fine the list is currently 14 WiFi networks. Are you saying new ones might be bumping old ones and so on because of some limitations of the list size? I tried creating my network manually already anyway - didn't help. Here's a screenshot illustrating my WiFi network present in inSSIDer yet missing from the Windows list: s22.postimg.org/m4fy4yfg1/Wi_Fi.png – dandreye Oct 16 '16 at 20:48
  • Channel 13, huh. That is also a potential problem because it's not legal in many countries. Try moving you network to another channel. – Daniel B Oct 16 '16 at 21:44
  • Daniel B: Spot on! Just tried a few other channels and it worked straight away. Interestingly whenever my router is set for Auto it seems to always choose #13 (tried twice). Leaving it at #3 for now. Much appreciated ) – dandreye Oct 16 '16 at 21:54
0

From your image, we can see that your WiFi network is using channels 9 through 13 (so actually 10 + 12 or something like that):

enter image description here

It seems I somewhat got the regulation backwards in my comment, but here’s the thing about channel 12/13: In the U.S., it is subject to special power limits to limit interference. Some manufacturers seem to take the easy way out and just disable that channel outright. World-wide, naturally, because they’re lazy.

So just move your network away from channels 12/13 and you should be good. It’s not that great for signal quality, seeing how there are lots of networks in your area, but you can’t really do anything about that.

  • Yeah I've done exactly that - by means of setting the country in my router to the US (it was set to the UK previously). Interestingly my WiFi adapter didn't have such setting, so I'm unsure how it'd possibly work in the US ) – dandreye Oct 24 '16 at 19:13

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.