3

I installed latest forticlient SSL VPN (5.4) and when I dial the VPN it connects successfully, but after about a minute the VPN disconnects.

The event viewer in "Application" under the source "RasClient" it says:

CoId={31DF16A3-7AC3-45CF-A5C5-07DF259A42EB}: The user SYSTEM dialed a connection named fortissl which has terminated. The reason code returned on termination is 829.

Any ideas anyone? I am working on this for 2 days without any luck...

Thanks!

  • I have the same problem! Just no idea what i need to fix... – marcolopes Nov 27 '17 at 3:26
2

I have been suffering from this issue for about 6 months. I made great progress today -

  1. I realized the VPN connection works reliably with a wired ethernet connection; the issue is only with wireless.
  2. I did an 'ipconfig /flushdns' from an admin command prompt, without rebooting, and that seemed to fix the problem when connected wirelessly.

I've tried multiple Forticlient versions, two different laptops, various wireless networks, etc - the problem is very consistent for the past 6 months (was solid before that, suggesting perhaps some Windows Update issue).

  • Thanks for sharing, I only have it at home at my wireless. It works on the wired connection. The flush dns command does work! Thanks! No idea how that is possible. – Maarten Kieft Mar 9 '19 at 13:09
  • Do you just do this once... or are you flushing every time you log in to VPN? – sam yi Aug 27 '19 at 14:43
0

Check your network devices for possible misconfigurations (ex. DHCP) some modem/routers needs ALG Settings to be enabled for Virtual Private Network(VPN) to work (ex. PPTP Pass-through..)

If you have other types of network disconnections you may also have to check your network/phone cables for possible failure.

As expained in social.technet.microsoft.com website:

Error 829 (ERROR_LINK_FAILURE)

Message: The modem (or other connecting device) was disconnected due to link failure.

This error appears when the modem (in the case of dial-up or broadband connections) or tunnel (in the case of VPN connections) is disconnected due to a network failure or a failure in the physical link to the modem. The following are possible reasons for the failure.

A problem in the network between the modem and the RAS server might have caused the basic dial-up or, in the case of a broadband connection, PPPoE connection, or VPN tunnel to fail.
Check connectivity between the modem and the telephone/cable connection jack. If an external modem is being used, check the physical connectivity between the modem and the computer.
In the case of VPN connections set up over a wireless network, problems in the wireless network might have caused the connection to fail. Check the status of the wireless connection in Network Connections folder.
Some of the causes of problems in the wireless network are:
    The wireless access point might have gone down due to loss of power or for other reasons.
    The user's computer might be out of the operating range of the wireless network or the RF signal strength might be weak.
The RAS server might have failed or restarted and closed the connection. Check the event logs on the RAS server.
  • Same problem here. My ISP says it's not the modem fault! Have no idea what to do... – marcolopes Nov 27 '17 at 3:25
0

Are you connected to a FortiClient Enterprise Management system server? If you click on the compliance tab in the FortClient do you see "This computer is connected to EMS:?

  • 1
    The Forticlient's default state is to stop the dnscahce service when it connects so DNS lookups on your network work better. This actually makes it worse. The better option is to restart the dnscache service so that it flushes your dns cache and keeps running. If not using a FortiEMS server for your Forticliet Settings [HKEY_LOCAL_MACHINE\SOFTWARE\WOW6432Node\Fortinet\FortiClient\Sslvpn] "WinDnsCacheService"=dword:00000002 If using FortiEMS then do this on the FortiEMS admin portal Local Profiles -> Profile -> VPN -> SSL VPN : DNS Cache Service Control -> "Restart dnscache service" – Ratlesnak11 Mar 21 '18 at 19:40

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.