9

Since upgrading to Windows10 AU, my desktop now displays a new icon in the upper left corner -- an italicized blue star labeled Quick Access, which functions as a shortcut to the Quick Access feature in the tree pane of File Explorer (Quick Access serving as an MRU or "Recents" list). I don't use the Quick Access feature in File Explorer, so I've followed instructions I found on line to eliminate the Q.A. gimmick there; and that removal worked successfully. But on the desktop, the blue star icon persists (though it sometimes disappears and reappears sporadically). Its context menu does not provide a Delete option. So: how can I get rid of this icon?

1
  • For future reference, this is a much better way to remove it from the File Explorer and you'll never run into this desktop icon mess again.[HKEY_LOCAL_MACHINE\SOFTWARE\Microsoft\Windows\CurrentVersion\Explorer] "HubMode"=dword:00000001 Apr 9, 2020 at 2:05

9 Answers 9

6
  1. Enter Registry Editor by typing regedit in the Run Command Box and go to registry path HKEY_CLASSES_ROOT\CLSID{679f85cb-0220-4080-b29b-5540cc05aab6} and Right Click it to see the Drop Down Menu.

  2. Enter ShellFolder >> Permission >> Advanced

  3. At the top of Advanced Security Settings for ShellFolder, change the ownership of the folder to Administrators.

    To do this, click Change, click Advanced, click Find Now, and from Search Results select Administrators, then click OK, OK again, then Apply, hit OK. Click Administrator and give Full Control and hit OK one last time to close the ShellFolder Permissions box.

    We can now change the setting to remove the Quick Access folder from File Explorer/Desktop.

  4. Inside ShellFolder, double-click Attributes, and change data value from a0100000 to a0700000, and click OK.

This should get rid of the Quick Access File Folder/Desktop icon.

4
  • 1
    My Attributes value was set to 0xa0600000. Changed it to 0xa0700000 and poof, QA icon was gone. Awesome, thank you!
    – PLN
    Jan 23, 2018 at 16:29
  • 1
    This is odd. I already did this and out of nowhere it changed from a070000 to a060000 (which is why I'm here). Seems like this will be an ongoing issue. I set my permissions back to stock after I made the change the first time, maybe that's the problem? Oct 22, 2018 at 22:39
  • 1
    @JustinEmlay I had this problem too, so I got a bit more serious with permissions changes. 1. Take ownership as outlined above. 2. On the "Advanced" tab add an entry granting your own user account (current owner) full access. 3. On the same tab, edit the permission for TrustedInstaler and change from Full Control to Read only. Seems to have fixed it.
    – dgnuff
    Mar 8, 2019 at 4:45
  • On Win10 Pro N, version 20H2, doing that lead to serious issues like not being able to open a single explorer instance.
    – bela83
    Nov 3, 2020 at 14:44
2

I haven't seen anything like that on my pair of Windows 10 machines following the Anniversary Update.

Have you already checked to ensure that the icon doesn't reside at the following location:

%SystemDrive%\Users\Public\Desktop

Taking is a step further, perhaps it is simply one of the new default desktop icons following the Anniversary Update, and you can turn it off accordingly:

  1. Open Settings
  2. Select Personalization
  3. Select Themes
  4. Click on the Desktop icon settings link on the right side under Related Settings
  5. Check or uncheck the Desktop icons you want, and then click on OK (as seen below)

Desktop Icons

(Source)

1
  • Run5k -- Thanks for giving it a shot. I appreciate your taking the time to show me in detail all the possible suspects, including a perfectly apt screen-shot with arrows and step-by-step instructions. Really very generous. But alas, no, it's not in the usual Desktop Icons Settings spot for easy deletion, nor is it in the folder you suggest. But let me show you a curiosity that is in the folder you mention: a desktop.ini file with the following two lines in it: [.ShellClassInfo] LocalizedResourceName=@%SystemRoot%\system32\shell32.dll,-21799 I looked at its properties, and found that that *.d Oct 21, 2016 at 21:38
0
  1. Open File explorer
  2. Right click Desktop
  3. Click Properties
  4. Uncheck Read only
  5. Apply Quick access icon is gone. I've checked later, and in the properties of Desktop, Read only was checked again by itself, but Quick access icon is still gone.
0

I had the same issue based on your description). I think I just solved it.

Try this:

Open the "File Explorer Options" Box, "General" Tab
(File Explorer > View > Options > General)

At the bottom and uncheck the two options at the bottom under "privacy" ("Show recently used files in Quick Access" and "Show frequently used folders in Quick Access")

I'm not certain you need them both unchecked but it's what I did--so far, so good. There is also a "Restore Defaults" button if it somehow makes things worse for you.

-1

This happened to me. To fix, Show system files in file explorer and delete desktop.ini from desktop folder.

-1

I have the same question to you. I solve the problem by the two methods as follows:

http://www.askvg.com/how-to-disable-quick-access-aka-home-view-in-windows-10-file-explorer/

https://productforums.google.com/forum/#!msg/chrome/MfJeLOqWOMs/ceMlGKUOCgAJ

I hope this method can help you.

2
  • 1
    You should quote and cite all relevant information from your links.
    – Ramhound
    Feb 11, 2017 at 7:15
  • Please quote the essential parts of the answer from the reference link(s), as the answer can become invalid if the linked page(s) change.
    – DavidPostill
    Feb 12, 2017 at 15:56
-2

I followed the suggestion to delete the "ini" file in explorer ,,however it appeared to be deleted from explorer but there still appeared to be an icon on the desktop and i couldn't move it to the trash bin...so i took ownership then renamed the file to .txt extenstion instead and then i was able to successfully delete it. not sure if it helps anyone else but it worked for me

1
  • This doesn't answer the author's question. Commentary shouldn't be submitted as an answer
    – Ramhound
    Aug 4, 2017 at 12:02
-2

For users who are not part of a network, the following worked for me:

  1. In "This PC," click "View," then "Options: Change folder and search options".
  2. Click the "View" tab.
  3. Scroll down and UNCHECK "Use Sharing Wizard"
  4. click "Apply" then "OK".

This immediately eliminated the Quick Access icon.

1
  • 2
    If possible, please explain the connection between disabling the Sharing Wizard and the Quick Access shortcut icon. Aug 11, 2017 at 22:01
-2

The HKEY_CLASSES_ROOT\CLSID{679... registry value a0700000 for Shellfolder (see Mason's answer above) is not appropriate, because it disables drag-dropping files from right pane to left pane. See here: How to enable drag-and-drop in(to) the navigation of the Windows 10 explorer?

Set "Attributes" key value rather to a6000000, then restart the explorer: in task manager find "Windows Explorer"; right-clic and restart this process; no reboot needed. And drag-drop is enabled again.

1
  • That creates a horrible permanent Quick Access Icon on your desktop and on the left hand area. Oct 22, 2018 at 22:41

Not the answer you're looking for? Browse other questions tagged or ask your own question.