6

This question has ben asked before but yet never answered. I have set up my Outlook 2016 with three different Mail accounts:

name@domain1.com (commertial, office365)
name@hotmail.com (personal, outlook.com account)
name@domain2.com (another company, office365)

The commertial account name@domain1.com now requires that the outgoing mails are signed with a S/MIME certificate. So I set up a certificate from COMODO, imported that into the trust center in outlook and everything seems to work fine.

The problem now is that the other two accounts name@hotmail.com and name@domain2.com dont need to be signed. Since I ticked the option "add digital signature to outgoing mails" in the trust center, outlook thinks I want to add a digital signature to every mail of every account. So it pops up a prompt everytime I want to send a mail from one of those two unsigned accounts. Setting it up to send it unsigned will send the mail, altough it wil promt it again the next time.

One option would be to untick "add digital signature to outgoing mails" in the trusting center but then the signing-option is turned off for the signed account. Ticking it for every mail manually is very unhandy...

So is there a way to set up outlook to ignore the signature for the two unsigned accounts or to tick the signing for outgoing mail from one single account by default?

2

The short answer I believe is no. This is setting is a profile setting, so all mail accounts on the same profile will inherit it. You could setup different profiles for each account, but that will require you close and restart outlook to access those accounts.

Two other methods that may work:

  1. VBA/Macros - Use these to create messages withs specific settings applied
  2. Outlook custom message templates. I did look at the available fields but didn't notice any for SMIME. I don't really use custom template so may have overlooked it or it may need to be implemented or access in some other way.
| improve this answer | |
2

I've been trying this problem for quite some time now. I even contacted microsoft support to check if they have any information on how to solve this. So their and my answer after investing an almost stupid amount of time is: There is no solution for this currently!

Since I cannot accept "no solution" answers concernig this problem, I developed an outlook addin which makes it possible to configure this and solve this problem for now. Its not completely finished yet but I'll put the source in a git repository as soon as im finished. I'll post the link down below.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.