6

tl;dr

My laptop computer running Linux is freezing randomly. What system tools can help to figure out what the problem is?

DISCLAIMER: I hope my question is not considered as a duplicate since most of the computer is freezing topics attend to running Windows OS.

The long story

My laptop computer is an Acer TravelMate B115-M which is about two years old by now. At first I was running Windows 8.1 for a long time and it was running very stable. But a year ago I finally switched to Linux trying out several distributions. Since then my system keeps freezing randomly.

This issue I am facing from the beginning when I switched to Linux. That's why I think it is not a hardware issue (although I tried to solve it by updating the system BIOS). Since then I was running Ubuntu and Kubuntu 14.04, Ubuntu Mate 16.04 and now Linux Mint 18 for several months. Started with Kernel 3.13 now Kernel 4.4 it is.

The symptom

By freezing I mean that the mouse pointer stops moving, no keyboard keys are working and the sound stops playing but the screen does not turn black. Also the emergency reboot by the magic SysRq key Alt+Print+B does not reboot the system. So I have to power cycle the system.

By random freezing I mean that there are days when my system is freezing up to two times within an hour. But also there is a time when my system is running for weeks not freezing at all. That's why it is very difficult for me to diagnose this issue.

System tools

I tried to get closer to that issue by investigating some logs. So I turned on persistence for journald and waited until the next freeze. After rebooting I took a look into the logs of the previous boot log by issuing the command sudo journalctl -b -1 and went straight to the end. Unfortunately there were no clues for any freeze or crash to find. No errors and no warnings!

So now I am asking for help. Does anyone have some helping hints to get behind the freezes? What system tools I can use to do further investigation by myself?

Thanks in advance!

EDIT

Just after asking my question I found another question facing the same issue. There the user named @spacelander points to a known bug regarding Intel Bay Trail CPUs in the linux kernel.

1

2 Answers 2

2

Edit /etc/defaults/grub:

GRUB_CMDLINE_LINUX_DEFAULT="intel_idle.max_cstate=1"

Run

update-grub
shutdown -r now
1
  • 1
    How does this solve the problem? In my case, it made the WiFi non-functional on rebooting.
    – Prajwal
    Jan 29, 2019 at 21:49
1

Although you have provided details about the symptoms, it it probably is still not enough data for a correct diagnosis. Other users may ask you for some logs.

However, I frequently experienced the same issue on my laptop. Turns out the culprit was a USB HDD I had connected.

Apparently, depending on your system settings, USB peripherals such as HDDs and dongles can freeze the user interface when transferring data. COnsequently, your system becomes completely unresponsive for a while, clicks do not work (neither mousemovement), and becaouse your keyboard gets ignored as well, no maigc key combination will work.

Now, I don't recall exactly why, but I belive it had something to do with the way I had configured my swap. You may take a look at this article.

I might be pointing you in the wrong direction, so discretion is advised ;) Good luck!

2
  • My laptop doesn't have /etc/sysctl.conf file. Do you know where it might be? or atleast it's equivalent. I'm using Manjaro OS (Arch based distro)
    – Prajwal
    Sep 5, 2018 at 12:27
  • Just google the mame of your distribución along "swapiness". I'm sure there will be several referencia pointing you to the right conf file ;) Sep 7, 2018 at 6:36

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .