0

I'm on openSUSE Leap 42.1 and I'm trying to make it work with the NVIDIA proprietary drivers.

At the moment, with the drivers installed via zypper or without proprietary drivers, my laptop (Acer F15 with a NVIDIA Geo Force 940M) is almost useless.

It freezes almost always using both KDE, GNOME and also other desktop environments. It seems a video driver problem and because of this I'm trying to install the proprietary drivers manually.

I downloaded the latest version (Also tried others).

When I installed it, run mkinitrd and blacklisted nouveau. Now I get a blank screen.

The log files says: xf86OpenConsole: VT_ACTIVATE failed: Operation not permitted

Tried to generate a new xorg.conf file via nvidia-config but nothing.

Tried su - -c chmod 4755 /usr/bin/Xorg but nothing also in this case.

Suggestions?

1 Answer 1

0

nvidia has official repository for its drivers:

http://http.download.nvidia.com/opensuse/leap/42.1

so correct way to install Nvidia drivers are :

  1. add nvidia repo zypper ar -f http://http.download.nvidia.com/opensuse/leap/42.1 nvidia
  2. zypper in x11-video-nvidiaG04 nvidia-gfxG04-kmp-default nvidia-glG04
0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.