0

c:\Windows\System32\drivers\etc\hosts

213.213.213.213  ken.bone.com kenneth.bone.com

I'm using a clean profile in both Firefox and Chrome with all privacy settings and prefetching disabled.

Verified:

  • pinging domains returns the correct IP
  • In Chrome: ref
    • Unchecked all the boxes under Privacy settings
    • Checked if the DNS prefetching is really disabled by going to chrome://dns
    • Host cache is cleared chrome://net-internals/#dns
    • Everything has been cleared since the beginning of time
    • Tried the --disable-async-dns option in Windows

In FF's Dev Tools under Headers, the remote address is a local IP as expected.

In Chrome's Dev Tools under Headers, the remote address is the remote IP which is not expected.

Why is Chrome not respecting the Windows hosts file?

Running Chrome 53 and Firefox 49 on Windows 10

  • I do this on a regular basis with Chrome (54 stable), use lots of VPN connections and need to resolve to "internal" addresses rather than public sometimes, and it works every time. I just need to reboot to get Chrome to see the change. Are you rebooting after editing the host file? – acejavelin Oct 18 '16 at 16:20
  • Thanks for the comment however restarting did not work – SomeGuyOnAComputer Oct 18 '16 at 16:37
  • I compared your answer to my settings, that option is enabled on my machine. Not really important since it worked for you, but Chrome honors the host file in my instance with or without this setting enabled. – acejavelin Oct 18 '16 at 16:42
0

Turns out my Work computer sets up an automatic configuration script known as a .pac (proxy autoconfiguration).

Steps to disable

  1. Settings > Network > Change Proxy Settings...
  2. Under Connections, click LAN settings, disable Use automatic configuration script
  3. Click OK
  4. For each Dial-up and Virtual Private Network settings and click Settings
  5. Repeat steps 2 and 3

This still seems like a Chrome problem to me because I feel that Chrome should respect my local hosts file before an automatic configuration script.

  • Sounds like Chrome is set up to use the proxy while FF is not. – Xalorous Oct 18 '16 at 16:44
  • How do you force Chrome to not use the proxy script and rely instead on the system hosts file like Firefox does? – SomeGuyOnAComputer Oct 18 '16 at 16:45

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.