1

I am using Cygwin64 2.6.0 under Windows 7.

Cygwin64 Terminal startups quickly if I don't set db_home variable in /etc/nsswitch.conf.

However if I set db_home to /%H, terminal startups very slow (30 seconds aprox.). I've googled a lot and check the Cygwin FAQ, but no luck. My HOME environment variable is correctly set, and Cygwin starts in my windows home folder.

Any idea what's happening? Thanks!

  • 1
    some file in the windows home folder has unknown ACL owner and cygwin hit a timeout asking for the relative info. It is usually better to not use the Windows Home folder as cygwin home. – matzeri Oct 19 '16 at 20:10
  • @matzeri any idea on how to find the file with ACL issues? I want to set my db_home as windows home to use the .ssh folder I have in windows. Thanks. – Javi Carnero Oct 20 '16 at 9:47
  • This was a while ago, but I have run in similar issues in a large corporation with AD authentication (e.g. slow app startup, slow file search operations). The culprit is windows access control used to emulate POSIX file permissions. Cf. cygwin.com/cygwin-ug-net/ntsec.html for background, and cygwin.com/cygwin-ug-net/ov-new.html#ov-new2.4s for the responsible ACL changes. One solution is to mount the drives with the noacl option by editing the /etc/fstab file (e.g. with a line none / cygdrive binary,posix=0,user,noacl 0 0), but then cygwin is crippled wrt file permissions. – Peter A. Schneider May 19 '17 at 9:52
  • Wrt sharing a Windows .ssh folder from cygwin: That direction should work quite well through a symbolic link from your cygwin home pointing to your Windows .ssh folder, I should think. (The other direction is less simple because Windows won't recognize simple cygwin symbolic links. With newer NTFS versions one can create native Windows links though.) – Peter A. Schneider May 19 '17 at 10:04

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Browse other questions tagged or ask your own question.