1

I ordered EasyCap, but it does not work on windows 10. I found driver for windows 10 online, but it didn't work. Someone knows how could I solve this problem? The device is recognized as an audio device also after I installed the driver. Thank you very much.

3
  • Define "didn't work".
    – ddbug
    Oct 20, 2016 at 1:49
  • Hi @ddbug, I installed it and PC does not recognize the peripheral device. Oct 20, 2016 at 5:34
  • This can be a device driver issue, such as failure to meet new signing requirements. Unfortunately it's hard to tell more without knowing more details on the problem (system logs, etc.)
    – ddbug
    Oct 21, 2016 at 23:35

5 Answers 5

3

EasyCAP DC60 Somagic 1c88:0007 / 1c88:003c

There are many different versions of hardware sold under the name of "EasyCAP". Some do not store the required firmware in EEPROM but expect the driver to feed the firmware into the USB hardware when inserted. The Somagic 1c88:0007 is one such device (there may be others). Once the firmware is loaded, the device ID changes to 1c88:003c.

The lack of firmware is why “VLC 3.0.4 Vetinari” can work with some EasyCAP hardware (those with built-in firmware) but not others. VLC > Open Media > Capture Device tab > Capture mode only lists DirectShow, “TV - digital”, and Desktop. There is no “USB cam”.

Windows 10 1803's Device Manager shows it under Other devices > Unknown device > Details tab > Device instance path> Value = USB\VID_1C88&PID_0007\SMBL007. Events tab will list entries such as: Device not migrated Device installed (smiusbgrabber3f.inf_... Info: Driver Management concluded the process to install driver smiusbgrabber3f.inf_amd64_62fdac16904230b7 for Device Instance ID USB\VID_1C88&PID_0007\SMBL007 with the following status: 0xE0000234.

The Somagic device driver is installed in C:\Windows\System32\DriverStore\FileRepository\smiusbgrabber3f.inf_amd64_62fdac16904230b7\SmiUsbGrabber3F.sys. Right click the .sys file > Properties. You will note there is no “Digital Signatures” tab. That means it is not “signed” which is required for Windows 10 kernel drivers. Compare this with C:\Windows\System32\drivers\storahci.sys which is signed.

You can search to disable Driver Signature Enforcement in Windows 10, but it will make your system less secure / more prone to malware. I’m not even sure if the driver will even work in Windows 10 with Driver Signature Enforcement disabled. It is only marked with Win7-64 on the CD label.

Two places point to the same Microsoft signed driver:

  1. https://www.youtube.com/watch?v=EjXSsv_rOmI

  2. https://answers.microsoft.com/en-us/windows/forum/windows_10-other_settings/i-need-sm-usb-007-driver/5746cf9b-b0c4-4a09-b15f-b66e82655e2e

    TonestarDeluxe 4/17/2017 9:58:25 PM

    • Uninstall the unknown device in device manager
    • Create a Windows restore point
    • Go to http://www.driverscape.com/download/sm-usb-007 and scroll down to the second last driver. Driver details should be:
      Driver Version: 1.0.8.28
      Release Date: 2011-01-26
      File Size: 546.04K
      Supported OS: Windows 10 64 bit, Windows 8.1 64bit, Windows 7 64bit
    • Download the zip file and extract to a folder (virus scan first of course!).
    • After the extraction, right click on the SmiUsbGrabber3C.inf file and select install. Your USB Device should be installed and recognised now. You may need to reboot if need be.

Windows 10 1809 (as of 2018-11-18) did not complain about the digital signature, but it complained about the Widows 95 era *.INF file and not being able to migrate the driver. Perhaps an older version of Windows 10 may work (until Microsoft pushes it to update).

Ubuntu 18.04.1 information about the EasyCAP device I bought via eBay:

$ sudo lsusb -d 1c88:0007 -v Bus 003 Device 011: ID 1c88:0007 Somagic, Inc. SMI Grabber (EasyCAP DC60+ clone) (no firmware) [SMI-2021CBE] Device Descriptor: bLength 18 bDescriptorType 1 bcdUSB 2.00 bDeviceClass 0 (Defined at Interface level) bDeviceSubClass 0 bDeviceProtocol 0 bMaxPacketSize0 64 idVendor 0x1c88 Somagic, Inc. idProduct 0x0007 SMI Grabber (EasyCAP DC60+ clone) (no firmware) [SMI-2021CBE] bcdDevice 1.00 iManufacturer 1 Somagic, Inc. iProduct 2 SM-USB 007 iSerial 3 SMBL007 bNumConfigurations 1 Configuration Descriptor: bLength 9 bDescriptorType 2 wTotalLength 18 bNumInterfaces 1 bConfigurationValue 1 iConfiguration 0 bmAttributes 0x80 (Bus Powered) MaxPower 200mA Interface Descriptor: bLength 9 bDescriptorType 4 bInterfaceNumber 0 bAlternateSetting 0 bNumEndpoints 0 bInterfaceClass 255 Vendor Specific Class bInterfaceSubClass 255 Vendor Specific Subclass bInterfaceProtocol 255 Vendor Specific Protocol iInterface 0 Device Qualifier (for other device speed): bLength 10 bDescriptorType 6 bcdUSB 2.00 bDeviceClass 0 (Defined at Interface level) bDeviceSubClass 0 bDeviceProtocol 0 bMaxPacketSize0 64 bNumConfigurations 1 Device Status: 0x0000 (Bus Powered)

Unfortunately, Linux support for this device is complicated to set up:

0

It's not the drivers I finally figured it out. It's the usb cable that comes with it. The usb cable that attaches to it and then you plug the other end to the computer .it is thin and cheaply made. Get your self a top of the line usb cable and you are good to go.I had one lying around my home and tried it and it works great. I thought it was the driver for a long time until it hit me try a quality usb cable. That is it just purchase a quality top of the line usb cable and your good to go. Post if it works for you. Take care

1
  • Just wanted to let you know that this solved my issue. If anyone else is having issues with drivers, check your USB cable first! The included cable may be faulty...
    – Novark
    Dec 27, 2019 at 9:08
0

As Phil's answer mentions, EasyCap does not need a driver if used with the free VLC player. Let me elaborate.

  • Once you open VLC, you click on the media tab.
  • Click open capture device.
  • Select USB cam and USB mic.
  • Then hit play
-1

I have sympathy with this problem and it took me ages to resolve. Even tried the remove / you name it solutions but narra.

There is a driver available on the following website: https://visser.io/2015/06/easycap-drivers-for-windows-8-1/

The driver file at the bottom to download is: EasyCap_W7_W10_x64.zip

Problem solved.

If it works for you, please let me know?

-1

EasyCap does not need a driver if used with free VLC Media Player https://www.videolan.org/vlc/index.html.

Not the answer you're looking for? Browse other questions tagged or ask your own question.