0

I've setup RDP on a workstation in our office and have set it up to use a custom TCP port. I've created a forward on our router/firewall for the port and workstation IP and have created the specific policies for that TCP port. I've created inbound and outbound rules in Windows Firewall for this port and have set it to Allow for all network types. This is all exactly the same procedure I have for another workstation with it's own custom port RDP setup and it works finr.

When I try to RDP in from outside the office, I cannot connect. If I disable the Windows Firewall and try again, it connects fine. I do not have this issue with the other workstation with custom port RDP.

What am I missing?

enter image description here

0

Can you show a screenshot of the Windows firewall rule? If you can disable the windows firewall rule and it works, there must be an issue with the Windows firewall. Can you insure that there isn't another firewall rule that could be conflicting with the rule in question? Maybe put the firewall rules in a different order so it hits the desired firewall rule first?

  • Screenshot added. In additon to everything I've mentioned above, I can RDP to this workstation from mine on the same LAN. If I remove that WF port rule, I can't RDP to it from the LAN anymore. Add it back and I have access again, but still not from an external computer unless the whole WF is disabled. – Reece Oct 20 '16 at 0:46
  • Furthermore, if I use canyouseeme.org on the workstation to check the port from outside, it shows as inaccessible. If I disabled the WF, it can be accessed successfully - so clearly my port forward is setup correctly. There's something going on with WF me thinks... – Reece Oct 20 '16 at 0:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.