6

Recently I have begun getting the following message in Firefox on about half the videos on YouTube, forcing me to use Chrome "Your browser does not currently recognize any of the video formats available":

enter image description here

When I get this I have to open Chrome and paste the URL in there to watch the video which is insanely annoying. Opening the info page (https://www.youtube.com/html5) shows the following:

enter image description here

How can I (A) find out what formats the video has, and (B) how to make Firefox support those formats?

(This is the latest version of Firefox, I do immediate updates whenever new versions come out. The current version is 49.0.2. This is a Windows box.)

  • 1
    Firefox supports HTML5 out of the box, unless you have disabled it, the behavior doesn't make sense – Ramhound Oct 20 '16 at 1:10
  • linuxveda.com/2015/04/02/… should also work on Windows – Ramhound Oct 20 '16 at 1:24
  • I agree with @Ramhound, isn't it possible that those videos are not Html5 videos? – RogUE Oct 20 '16 at 2:47
  • Besides the fact the screenshots indicate they are? We know nothing about the OS or version of Firefox. It could be Firefox 3 for all we know :$ – Ramhound Oct 20 '16 at 3:30
  • To answer question (A), go to another browser/computer that does work and visit the same video, right click on the video and go to the "Stats for nerds" option. The format is under the Mime Type section. For part B see music2year's answer. – Scott Chamberlain Oct 27 '16 at 5:34
5

This problem occurred when I watch a YouTube live video with Firefox on Ubuntu.

Installing ffmpeg solved my problem:

sudo apt install ffmpeg or

Same fix on Fedora 26 Workstation with Firefox 56 (x64):

sudo dnf install ffmpeg

  • Solved for me minimal installation Ubuntu 18.04 – Evandro Pomatti Aug 25 at 3:36
3

Tyler, as others have mentioned Firefox supports HTML5 video natively. If your Firefox installation does not, please try the following steps:

First, disable all the add-ons in your browser and try visiting Youtube again. If Youtube works, you can go through and enable single add-ons at a time, testing each time to make sure video plays correctly.

Next, if you're still not able to play Youtube videos natively, remove Firefox entirely and then go to https://www.mozilla.org/en-US/firefox/new/ and download a fresh copy of the latest version and install it.

UPDATE: More clarity on HTML5

HTML 5 is essentially a container, a WAY to deliver video, it is not the video codec itself.

In the picture you show, the HTMLVideoElement is the code that Youtube uses that the browser knows how to handle, but it doesn't actually encode the video, it's just the container the video is delivered in.

The video itself must be encoded in one of several formats, which are the other parts of the picture: h264, WebM, MSE, etc.

So, your browser knows how to handle the container, but it should also know how to handle the encoding formats itself, and that is where your problem lies.

If you look into the Stats For Nerds that @Scott Chamberlain mentions in his comment above, you will never see HTMLVideoElement listed as the encoding format. You will, however, find each Youtube video is encoded using h264 or WebM or MSE, and, once again, this is what your browser is failing to do and what you must troubleshoot, and the steps I've outlined above are the correct first steps to doing so.

  • Did you even read the question? MY BROWSER SUPPORTS HTML5. The problem is that doesn't support the ALL THE OTHER FORMATS. Maybe actually read the question? Also, this "answer" doesn't even attempt to answer question (A). – Tyler Durden Oct 26 '16 at 23:56
  • Dear Tyler, we know Firefox supports HTML5 video AND these formats, as the comments indicate. And there is not much reason to suspect that Youtube videos are NOT HTML5 as all Youtube videos are transcoded to that format before they can be viewed now. So the reasonable conclusion is that there is something wrong with your browser, and these steps are normal "something is wrong with your browser" troubleshooting steps. – music2myear Oct 27 '16 at 0:09
  • 1
    For instance, I am using Firefox right now, and have just visited the youtube HTML5 testpage and confirmed that all 6 of those format boxes test positive on my browser. This is further evidence that troubleshooting must begin with your browser. – music2myear Oct 27 '16 at 0:11
1

The problem was/is that Firefox uses Adobe Flash to play all movie types, except HTML, so if Flash is blocked for any reason, then you get the message shown in the question.

In my case several configuration items and protective Add-ons are in place to block Flash (because we know great Flash's security is, heh), so it was being silently blocked, thus preventing the videos from playing.

By tweaking my settings I was able to remove the silent block and make it a case-by-case block, so now I can approve videos and YouTube is working once again.

Apparently changes in various Add-Ons and in Firefox itself only caused this to be a problem recently. The relevant Add-ons in my case are: Flash, NoScript and FlashStopper.

1

My FIX: I went to https://www.youtube.com/html5 (Thx Grandpa Dave!), - Scrolled to the BOTTOM YOUTUBE LOGO on left- and just to the RIGHT of the bottom-left logo "LANGUAGE" and CORRECTED my location/LANGUAGE.

Everything played fine after that. Pls share if this worked for you. It's a weird auto-location selection. I thought there might be a prob when the comp auto-filled my date/time with another country time, sure enough, youtube matched the incorrect auto location.

0

Are you using some Linux distro? (if so, what?)

Go to about:config and look for "video", then check whether it's all default, and it's enabled. Maybe you don't have h.264 proper codecs; then you must have gstreamer bad and ugly if using Ubuntu, or other codecs if another distro, this assuming you're using Linux.

0

You can use vlc player to find out which format a video has .

1. Just open network stream -> enter youtube url -> right klick -> tool -> codec information

2. Some Firefox plugins lead from time to time to strange behaviors of Flash and HTML5 Player. Add youtube.com as exception by Flashblock etc ....

3.Check under about:config if the following values enabled:

media.webm.enabled 
  1. Run -> sudo apt-get update && sudo apt-get upgrade
0

This happend to me in Opera after updating to the latest version of Ubuntu. Oddly enough, the problem seemed to be with Flash. Uninstalling everything associated with flash player from the computer and then installing the Opera extension fixed the problem.

0

This add-on solve the problem, it requires Flash Player.

https://addons.mozilla.org/fr/firefox/addon/youtube-flash-video-player/

  • This is not a solution. Flash Player support for Linux was dropped by Adobe in 2012 and only old versions are available. By the end of 2016 YouTube converted their entire video collection to non-Flash. Flash is obsolete. – Andrew P. Apr 5 '17 at 17:57
-1

same problem for me. Ubuntu 16.04 Firefox 55.0.2 (64-bit) add-ons include flash. The fix was to disable flash by clicking the f icon. The video then played fine. Note that I had all positive browser support checkmarks on the "YouTube HTML5 Video Player" page, and they did not change when I toggled flash On or Off, (https://www.youtube.com/html5)

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.