1

Please, do not consider this question as a duplicate of this one -- it’s not an Intel graphics problem in my case and the issue is a bit different.


I’ve got a new PC with Windows 10 and experiencing a weird issue with USB devices.

Issue

When mouse cursor icon changes (like when hovering a browser URL link or a text field) a USB lag between 500ms to 2seconds occurs. By USB lag I mean that any device connected to any USB port stops responding: mouse stops moving, keyboard not responding, audio drops out (I use an external USB audio interface). It’s not happening at each transition, but somewhat randomly, though quite persistently.

Imagine moving mouse cursor over a Google search results page: the cursor state will change to hand when hovering a URL link, to text selection when hovering description text below the links and to pointer when in the “free” areas. In my case mouse will constantly lag and the sound drop-out if I would just move the cursor over such page.

System info

  • OS: Windows 10 Pro
  • CPU: Intel Core i7 6900K
  • Motherboard: ASUS X99-A
  • GPU: ASUS STRIX GTX1080-O8G-GAMING
  • DDR: 8x8GB, DDR4, Crucial Ballistix Elite, 2666 Mhz
  • SSD: 2 TB, Samsung 850 PRO
  • HDD: 3Tb SATA-III Western Digital Red (WD30EFRX)
  • External USB devices: wireless mouse (Logitech G900), wireless keyboard (Logitech K800), USB 2.0 Audio Interface (Roland QUAD-CAPTURE)

What I’ve tried

  • Using Windows Clean Boot – the issue persisted;
  • Installing fresh Windows 10 – issue occurs right from the start;
  • Trying different drivers for the USB devices/controllers and the MB chipset – no changes;
  • Trying different NVidia drivers – no changes;
  • Updating motherboard BIOS to the latest version – no changes;
  • Switching HCI mode in BIOS – there was definitely some effect here. In EHCI mode (USB 2) the mouse lags were much more noticeable, while the audio drop-outs were at minimum, and in xHCI (USB 3) it was vice-versa: more audio lags and less mouse;
  • Using different USB ports – there was some subtle difference depending on what USB ports I’ve used. When a device is connected to an Intel USB controller port the lags are more frequent, while ASMedia’s ports had less issues;
  • Disabling any power saving features in BIOS, Windows power management and in the device manager for each of the USB devices and USB controllers – no difference;
  • Unplugging all the USB devices except the mouse – no changes;
  • Using different mouses (both wired and wireless) – no changes;
  • Trying another GPU – no changes;
  • Trying another Motherboard (ROG STRIX X99) – completely solved mouse lag issue, but audio drop-outs persisted in xHCI mode;
  • Disabling all the mouse features in Windows mouse settings (enhance pointer precision, pointer trails, pointer hiding when typing, pointer shadow) – no changes, except for trails (more on that below).

The weird

Now, the weirdest thing about this: enabling the “display pointer trails” option in the Windows mouse settings completely solves the issue! I can’t really comprehend why this happening, how could such “cosmetic” option affect all the USB devices in the system? I’ve set the trail distance to be as short, as possible, but it’s still noticeable and quite distracting, so I’m looking for a way to fix the issue without enabling the trails.

  • Pointer trails are a graphical thing, which, like the answers on the questioned you linked, are primarily enabled and affected by your graphics driver. You say you used a fresh install of Windows, and that you updated the BIOS and USB device drivers, but did you also install the latest video drivers form nVidia, as well as the chipset and USB controller drivers from the manufacturer (Intel and/or Asus, preferably Intel). Also, if you do a Clean Boot of Windows 10, does the problem persist? – Ƭᴇcʜιᴇ007 Oct 20 '16 at 12:35
  • Yes, I've tried different nVidia drivers (the latest and the oldest, which were available for my GPU) -- no changes there. I've also installed latest Intel chipset drivers (tried versions from both Asus and Intel websites) and ASmedia USB controller driver -- no luck either. Checked the clean boot (thanks for the tip, btw) -- the problem persisted. – Elringus Oct 20 '16 at 13:15
  • Then it sounds like a hardware issue to me, so I'd say it's time to take it back to where you bought it and cash in the warranty... – Ƭᴇcʜιᴇ007 Oct 20 '16 at 13:29
  • Hm, how it could be a hardware issue when enabling pointer trails fixes it? Isn't it something OS/drivers related? – Elringus Oct 20 '16 at 13:58
  • You're tried a fresh OS install, and tried ensuring all your drivers were updated (and also did plenty of trials with other versions even). So as far as I'm concerned, you've proven it's not a software issue. Assuming you have hardware laying around to test with, try a different (known-good) video card and see if it makes any difference. If you don't have spare hardware laying around, then take advantage of your warranty and take it back to someone who presumably does, so they can figure out what's going on, and/or gives you a replacement that works as it should. – Ƭᴇcʜιᴇ007 Oct 20 '16 at 14:03
0

I was able to avoid the same reproducible problem with my Universal Audio Apollo Twin USB 3.0 audio interface by using their latest driver 9.2 in which they have added the new option "USB Safety Buffer", which is part of the "USB Audio Transfer protocol 2.0" which has been added to Windows 10 with the Creators Update.

You might need a new audio driver from Roland which supports the "USB Audio Transfer protocol 2.0" for Windows 10 incl. Creators Update.

In my case LatencyMon reported dxgkrnl.sys with highest execution of 1.6 ms which is too high (max 1.0 ms allowed). I think in my case its the Intel Display Driver 630 which doesn't return fast enough to dxgkrnl.sys (as far as I understand). I would have to report this to Intel.

In the audio driver I had to increase the USB Safety Buffer from "Minimal" to "Small" and until today I had no audio drop outs anymore. As far I understand, "Small" adds 1 ms to standard 1 ms - in total 2 ms time before audio drop outs could occur.

Please read my Intel report: https://communities.intel.com/message/483201

If your are not able to get a new audio driver - try to use LatencyMon and contact the driver providers.

  • Thank you for the info! I've checked and it seems like Roland haven't updated QuadCapture drivers since 2015. I'll try contacting them about the issue, though I'm not really hoping for any response :) – Elringus Jun 26 '17 at 20:31

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.