1

I have an issue in PowerShell ISE (Windows 7) where it takes around 2-3 seconds after copying some text from the scripting area before it actually saves into the clipboard. During this time the ISE window is unresponsive.

I don't experience this on any other machine, only my main computer at work, and I can't seem to find anything else on the internet about it.

My PC has done this for as long as I can remember, so still experiencing the issue after many a PC and ISE restart.

I also noticed the delay is present no matter how I copy the text:

Ctrl + C

Right-Click + 'Copy'

$ "test text" | clip

Does anyone know what causes this issue, and how I can resolve it?

Thanks

  • 1
    Have you tried launching the ISE without a profile? powershell_ise.exe -NoProfile – root Oct 20 '16 at 16:01
  • @root Thanks for your comment - just tried that and there is still about a 2 second delay when copying – Bassie Oct 20 '16 at 16:03
  • 1
    Are other copy to clipboard commands slow as well? Have you tried restarting PowerShellI ISE? Have you tried restarting your computer? – DavidPostill Oct 20 '16 at 17:26
  • 2
    i'd first try a sfc /scannow which almost never helps but still is a good starting point. if that doesn't cure the issue, have you considered updating your PowerShell to a new version? – SimonS Oct 25 '16 at 12:19
  • 1
    @SimonS I think the sfc /scannow actually did it! – Bassie Oct 25 '16 at 14:12
1

use sfc /scannow to scan and repair missing or corrupted system files.

To view the log of the sfc execution, use:

findstr /c:"[SR]" %windir%\Logs\CBS\CBS.log >"%userprofile%\Desktop\sfcdetails.txt"

More Information: https://support.microsoft.com/en-us/kb/929833

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.