1

I am using a Sony vaio with Xubuntu - Ubuntu 16.04.1.

Struggling with an odd problem browsing the internet. I am connected the internet but can't access any website except Gmail and Google search engine or Yahoo, without being able to access any link through the result of my search, I was able to use software center to download chromium since I thought Firefox my default browser had an issue but I got the same behaviour from Chromium.

Using terminal I got these info:

sa@sa-VPCW11S1E:~$ route
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
sa@sa-VPCW11S1E:~$ ipconfig
No command 'ipconfig' found, did you mean:
 Command 'ifconfig' from package 'net-tools' (main)
 Command 'iconfig' from package 'ipmiutil' (universe)
 Command 'iwconfig' from package 'wireless-tools' (main)
ipconfig: command not found
sa@sa-VPCW11S1E:~$ ifconfig
enp2s0    Link encap:Ethernet  HWaddr 00:24:be:02:ee:c8  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:2004 errors:0 dropped:0 overruns:0 frame:0
          TX packets:2004 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:172993 (172.9 KB)  TX bytes:172993 (172.9 KB)

wlp3s0    Link encap:Ethernet  HWaddr 00:1f:3a:fa:28:44  
          inet6 addr: fe80::d441:1543:60ed:70a2/64 Scope:Link
          inet6 addr: 2a02:1205:504e:f700:8c07:b952:591d:f8c0/64 Scope:Global
          inet6 addr: 2a02:1205:504e:f700:406:ff40:6767:4e81/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:130950 errors:0 dropped:137 overruns:0 frame:0
          TX packets:64181 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:153436646 (153.4 MB)  TX bytes:7818221 (7.8 MB)

sa@sa-VPCW11S1E:~$ sudo service network-manager restart
[sudo] password for sa: 
sa@sa-VPCW11S1E:~$ ping wwww.ba.com
ping: unknown host wwww.ba.com
sa@sa-VPCW11S1E:~$ ping www.google.com
connect: Network is unreachable
sa@sa-VPCW11S1E:~$ 

I appreciate the comments and tips, after trying several times I was able to set up a static ipv4 addresse and it work , can't recall how I did it since I was following a toturial, but the next day I got back to the same problem and my current configuration as this;

ifconfig;

sa@sa-VPCW11S1E:~$ ifconfig
enp2s0    Link encap:Ethernet  HWaddr 00:24:be:02:ee:c8  
          UP BROADCAST MULTICAST  MTU:1500  Metric:1
          RX packets:0 errors:0 dropped:0 overruns:0 frame:0
          TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)

lo        Link encap:Local Loopback  
          inet addr:127.0.0.1  Mask:255.0.0.0
          inet6 addr: ::1/128 Scope:Host
          UP LOOPBACK RUNNING  MTU:65536  Metric:1
          RX packets:9393 errors:0 dropped:0 overruns:0 frame:0
          TX packets:9393 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1 
          RX bytes:823872 (823.8 KB)  TX bytes:823872 (823.8 KB)

wlp3s0    Link encap:Ethernet  HWaddr 00:1f:3a:fa:28:44  
          inet addr:192.168.1.8  Bcast:192.168.1.255  Mask:255.255.255.0
          inet6 addr: fe80::d441:1543:60ed:70a2/64 Scope:Link
          inet6 addr: 2a02:1205:504e:f700:8c07:b952:591d:f8c0/64 Scope:Global
          UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
          RX packets:98000 errors:0 dropped:411 overruns:0 frame:0
          TX packets:19165 errors:0 dropped:0 overruns:0 carrier:0
          collisions:0 txqueuelen:1000 
          RX bytes:43087964 (43.0 MB)  TX bytes:2701583 (2.7 MB)

route -n;

sa@sa-VPCW11S1E:~$ route -n
Kernel IP routing table
Destination     Gateway         Genmask         Flags Metric Ref    Use Iface
0.0.0.0         192.168.3.1     0.0.0.0         UG    0      0        0 lo
0.0.0.0         192.168.1.1     0.0.0.0         UG    600    0        0 wlp3s0
169.254.0.0     0.0.0.0         255.255.0.0     U     1000   0        0 wlp3s0
192.168.1.0     0.0.0.0         255.255.255.0   U     600    0        0 wlp3s0
sa@sa-VPCW11S1E:~$ 

traceroute www.google.com;

sa@sa-VPCW11S1E:~$ traceroute www.google.com
traceroute to www.google.com (172.217.19.4), 30 hops max, 60 byte packets
 1  * * *
 2  * * *
 3  * * *
 4  * * *
 5  * * *
 6  * * *
 7  * * *
 8  * * *
 9  * * *
10  * * *
11  * * *
12  * * *
13  * * *
14  * * *
15  * * *
16  * * *
17  * * *
18  * * *
19  * * *
20  * * *
21  * * *
22  * * *
23  * * *
24  * * *
25  * * *
26  * * *
27  * * *
28  * * *
29  * * *
30  * * *
sa@sa-VPCW11S1E:~$ 

Could somebody please explain to me the conflict here or the problem, kind of lost here

All right as requested the output of telnet n.a..com 80

sa@sa-VPCW11S1E:~$ telnet www.ba.com 80 Trying 104.66.171.91... telnet: Unable to connect to remote host: Connection timed out sa@sa-VPCW11S1E:~$

****Current configurations ***** sa@sa-VPCW11S1E:~$ ifconfig enp2s0 Link encap:Ethernet HWaddr 00:24:be:02:ee:c8
UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:17370 errors:0 dropped:0 overruns:0 frame:0 TX packets:17370 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1 RX bytes:1418792 (1.4 MB) TX bytes:1418792 (1.4 MB)

wlp3s0 Link encap:Ethernet HWaddr 00:1f:3a:fa:28:44
inet addr:192.168.1.8 Bcast:192.168.1.255 Mask:255.255.255.0 inet6 addr: fe80::d441:1543:60ed:70a2/64 Scope:Link inet6 addr: 2a02:1205:504e:f700:8c07:b952:591d:f8c0/64 Scope:Global UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:1672187 errors:0 dropped:819 overruns:0 frame:0 TX packets:1057202 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:2009166409 (2.0 GB) TX bytes:212308493 (212.3 MB)

sa@sa-VPCW11S1E:~$ route -n Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 0.0.0.0 192.168.1.1 0.0.0.0 UG 600 0 0 wlp3s0 169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlp3s0 192.168.1.0 0.0.0.0 255.255.255.0 U 600 0 0 wlp3s0 sa@sa-VPCW11S1E:~$

and the file /etc/network/interfaces

interfaces(5) file used by ifup(8) and ifdown(8)

auto lo iface lo inet static address 192.168.1.1 gateway 192.168.1.1 netmask 255.255.255.0 network 192.168.1.0 broadcast 192.168.1.255 dns-search example.com dns-nameservers 192.168.1.1 192.168.8.10

also resolv.conf;

Dynamic resolv.conf(5) file for glibc resolver(3) generated by resolvconf(8)

DO NOT EDIT THIS FILE BY HAND -- YOUR CHANGES WILL BE OVERWRITTEN

nameserver 192.168.3.45 nameserver 192.168.8.10 nameserver 127.0.1.1 search example.com 8.8.4.4 home

last is interfaces-order;

interface-order(5)

lo.inet lo.inet6 lo.@(dnsmasq|pdnsd) lo.!(pdns|pdns-recursor) lo tun* tap* hso* em+([0-9])?(+([0-9]))* p+([0-9])p+([0-9])?(+([0-9]))* @(br|eth)([^.]).inet6 @(br|eth)([^.]).ip6.@(dhclient|dhcpcd|pump|udhcpc) @(br|eth)([^.]).inet @(br|eth)([^.]).@(dhclient|dhcpcd|pump|udhcpc) @(br|eth)* @(ath|wifi|wlan)([^.]).inet6 @(ath|wifi|wlan)([^.]).ip6.@(dhclient|dhcpcd|pump|udhcpc) @(ath|wifi|wlan)*([^.]).inet

This is the latest config to shorten the "chat" the the comment section

sa@sa-VPCW11S1E:~$ sudo ifconfig [sudo] password for sa: enp2s0 Link encap:Ethernet HWaddr 00:24:be:02:ee:c8
UP BROADCAST MULTICAST MTU:1500 Metric:1 RX packets:0 errors:0 dropped:0 overruns:0 frame:0 TX packets:0 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:0 (0.0 B) TX bytes:0 (0.0 B)

lo Link encap:Local Loopback
inet addr:127.0.0.1 Mask:255.0.0.0 inet6 addr: ::1/128 Scope:Host UP LOOPBACK RUNNING MTU:65536 Metric:1 RX packets:238 errors:0 dropped:0 overruns:0 frame:0 TX packets:238 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1 RX bytes:17585 (17.5 KB) TX bytes:17585 (17.5 KB)

wlp3s0 Link encap:Ethernet HWaddr 00:1f:3a:fa:28:44
inet addr:192.168.1.115 Bcast:192.168.1.255 Mask:255.255.255.0 inet6 addr: fe80::d441:1543:60ed:70a2/64 Scope:Link inet6 addr: 2a02:1205:504e:f700:8c07:b952:591d:f8c0/64 Scope:Global UP BROADCAST RUNNING MULTICAST MTU:1500 Metric:1 RX packets:363 errors:0 dropped:0 overruns:0 frame:0 TX packets:97 errors:0 dropped:0 overruns:0 carrier:0 collisions:0 txqueuelen:1000 RX bytes:52244 (52.2 KB) TX bytes:15243 (15.2 KB)

sa@sa-VPCW11S1E:~$ routen'n

^C sa@sa-VPCW11S1E:~$ route -n Kernel IP routing table Destination Gateway Genmask Flags Metric Ref Use Iface 0.0.0.0 192.168.1.1 0.0.0.0 UG 600 0 0 wlp3s0 169.254.0.0 0.0.0.0 255.255.0.0 U 1000 0 0 wlp3s0 192.168.1.0 0.0.0.0 255.255.255.0 U 600 0 0 wlp3s0 sa@sa-VPCW11S1E:~$

migrated from serverfault.com Oct 20 '16 at 15:14

This question came from our site for system and network administrators.

  • dude you don't even have IPv4 address ...... so your only following ipv6 it's magic that you can even reach google :D but that's the thing make sure that you have ipv4 set up correctly then try to reach outside world..... i know that ipv6 is already on world but not as we can see on this example tools are already prepared to be using solely 6 – Michal Oct 20 '16 at 10:44
  • Oh well since you realized from my post that my knowledge in this matter is minimal to even notice that I dont have an ipv4 address I think it would been wiser to instruct me on how to do so. Well I did dfolliw your note and tried to apply the instructions in ythe folliwing link but still no change other than the ip address i assignd appread when i ifconfig (inet addr 192.168.0.100) just like thr link, since i wasnt sIure how to choose one . tecmint.com/set-static-ip-address-in-ubuntu-15-10-server – madnomad10011 Oct 20 '16 at 13:16
  • Make sure you have a gateway configured as well, and you are able to ping that gateway. Hope this helps! – Anirudh Malhotra Oct 20 '16 at 15:32
  • @Ainrudh_Malhotra could you please check my update on the main post as the problem still exist and I think I don't have the gateway set up properly – madnomad10011 Oct 27 '16 at 11:00
3

I see you have IPv6 addresses only configured on wlp3s0 interface

inet6 addr: 2a02:1205:504e:f700:8c07:b952:591d:f8c0/64 Scope:Global

inet6 addr: 2a02:1205:504e:f700:406:ff40:6767:4e81/64 Scope:Global

So all those websites which are accessible or hosted on IPv6 address will be accessible like www.google.com

dig www.google.com AAAA

; <<>> DiG 9.10.3-P4-Ubuntu <<>> www.google.com AAAA
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 33677
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;www.google.com.            IN  AAAA

;; ANSWER SECTION:
www.google.com.     300 IN  AAAA    2404:6800:4002:804::2004

;; Query time: 151 msec

And all those which are not hosted over IPv6 won't work, like www.ba.com

dig www.ba.com AAAA

; <<>> DiG 9.10.3-P4-Ubuntu <<>> www.ba.com AAAA
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 30440
;; flags: qr rd ra; QUERY: 1, ANSWER: 2, AUTHORITY: 1, ADDITIONAL: 1

;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
;; QUESTION SECTION:
;www.ba.com.            IN  AAAA

;; ANSWER SECTION:
www.ba.com.     60  IN  CNAME   www.ba.com.edgekey.net.
www.ba.com.edgekey.net. 21600   IN  CNAME   e8308.b.akamaiedge.net.

;; AUTHORITY SECTION:
b.akamaiedge.net.   1000    IN  SOA n0b.akamaiedge.net. hostmaster.akamai.com. 1476968242 1000 1000 1000 1800

;; Query time: 354 msec

As of why ping and route commands are not working

sa@sa-VPCW11S1E:~$ route

Kernel IP routing table Destination
Gateway Genmask Flags Metric Ref Use Iface

sa@sa-VPCW11S1E:~$ ping wwww.ba.com

ping: unknown host wwww.ba.com

sa@sa-VPCW11S1E:~$ ping www.google.com

connect: Network is unreachable

IPv6 commands for these two utilities are a bit different, Use :

route -6
ping6 www.google.com

It is showing unknown host for www.ba.com, Since it was not able to resolve its AAAA(or IPv6) record. Also it is showing Network is unreachable for www.google.com is because you have not used ping6 utility so it tries to reach IPv4 address of www.google.com which in this case is impossible as there is no IPv4 address on the interface.

  • Great explanation helped understand the problem, and i was able for a day establish ipv4 to reach other website, but currently the problem came up again , the current config is in the main post as I updated it – madnomad10011 Oct 27 '16 at 11:04
  • I see you have an IPv4 address now. But still the default route is not towards wlp3s0, You are still getting the default route 0.0.0.0 192.168.3.1 0.0.0.0 UG 0 0 0 lo . So check for following things 1.) Are you able to ping 192.168.1.1, if you are just delete the route with metric 0 2.) route del -net 0.0.0.0 netmask 0.0.0.0 gw 192.168.3.1 dev lo. Hope this helps if it did, Please mark this answer as answered or helped. – Anirudh Malhotra Oct 27 '16 at 13:54
  • Well I see now and i understand the output of route -n command also the command to delete gw 192.168.3.1 which I did and confined by route -n which did not show lo anymore on the list although the problem persisted unfortunately , with no response when trying to ping www.Google – madnomad10011 Oct 29 '16 at 15:59
  • I could still ping 192.168.1.1 but can't reach other websites on broswer other than Gmail, Google search engin and Yahoo. – madnomad10011 Oct 29 '16 at 16:06
  • Can you show output of telnet google.com 80 and telnet ba.com 80 – Anirudh Malhotra Oct 29 '16 at 16:21

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.