2

A few days ago my win10 pro machine (x64/build 14393) stopped opening the start menu (which is not so important since I still can use ClassicShell), and - more importantly - the info center and all apps are missing (including Microsoft Edge).

I've tried a few things to solve the problem. Among these are:

The Get-AppXPackage -AllUsers returns the following error (I use a german language Windows but I found a translation):

PS C:\WINDOWS\system32> Get-AppXPackage -AllUsers
Get-AppXPackage : Das Datenbank-Datenträgerimage ist falsch formatiert.
Das Datenbank-Datenträgerimage ist falsch formatiert.
In Zeile:1 Zeichen:1

translating to:

Get-AppXPackage : The database disk image is malformed
The database disk image is malformed
At line:1 char:1

What can I do to fix these issues (I believe the Get-AppXPackage error message and the other things might be related)?

Here are the outputs of the things I've tried:

C:\WINDOWS\system32>sfc /scannow

Systemsuche wird gestartet. Dieser Vorgang kann einige Zeit dauern.

Überprüfungsphase der Systemsuche wird gestartet.
Überprüfung 100 % abgeschlossen.

Der Windows-Ressourcenschutz hat keine Integritätsverletzungen gefunden.

C:\WINDOWS\system32>dism /online /cleanup-image /restorehealth

Tool zur Imageverwaltung für die Bereitstellung
Version: 10.0.14393.0

Abbildversion: 10.0.14393.0

[==========================100.0%==========================] Der Wiederherstellungsvorgang wurde erfolgreich abgeschlossen.
Der Vorgang wurde erfolgreich beendet.

C:\WINDOWS\system32>
  • 1
    So what was installed a few days ago? What you describe, means your entire UWP stack is corrupt, which means unless you want to Reset your installation you will have to download an ISO and point Get-AppXPackage to that source instead. – Ramhound Oct 20 '16 at 20:21
  • The two things mentioned in my updated report + Microsoft Office Pro Plus 2016 (this one I don't want to remove and I don't really understand why it has a recent install date, since I have it on the machine for some time). Updates: KB3199209, KB3194798 are shown to be installed during last week. Since I'm using Classic Shell and Firefox mainly, I might not have noticed the issues immediately but it shouldn't be there more than a week. – Alexander Remesch Oct 20 '16 at 20:26
  • How recently did you upgrade to 1607? – Ramhound Oct 20 '16 at 20:29
  • Can you expand on that please? I would certainly like to avoid a fresh installation. So I can fix the Universal Windows Platform stack without doing a fresh install? – Alexander Remesch Oct 20 '16 at 20:30
  • Also I did an update of Cygwin last week and I removed the Beta of Windows Subsystem for Linux. The 1607 update was probably end of August. – Alexander Remesch Oct 20 '16 at 20:33
0

I recently faced exactly the same problem. About 10 minutes after a fresh install, all the above functionality (Edge, Start Menu, Calculator, Notification Center, Search, etc) stopped working. Also for me the troubleshooter mentioned Microsoft.Windows.ShellExperienceHost and Microsoft.Windows.Cortana were not installed correctly.

SOLUTION: I finally traced it down to a conflicting NVIDIA graphics driver being automatically installed by Windows (for my external video card). After installing the latest driver update from the NVIDIA website (+restart) my problems were resolved and the troubleshooter completed without finding any issues.

Although this may not be the problem in your case (as you mention it may have been your SSD), all the symptoms were the same for me. And as the solution is not obvious (from what the troubleshooter says) I decided to share it here.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.