0

Usually, the program that opens a file type is stored in the following key in the registry (where filetypename is the name of the file type):

HKEY_CLASSES_ROOT\filetypename\shell\Open\command

But for image files such as PNG or JPG, the only key in the shell key is printto, which is the Print command. However, when I right click on the image, there is still an Open command, but it doesn't seem to be anywhere in the registry. Why is this? Can files have commands that aren't in the registry? Or is this command's key somewhere else in the registry?

-1

I know this because I just did it for "Edit with VbsEdit", a custom change for the .vbs filetype. This worked on a Windows 7 machine, after I created each key from ".vbs" down to "Command":

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SystemFileAssociations\.vbs\Shell\Edit with VbsEdit\Command]="C:\Program Files (x86)\Vbsedit\Vbsedit.exe" "%1"

Obviously, for your question use:

[HKEY_LOCAL_MACHINE\SOFTWARE\Classes\SystemFileAssociations\filetypename\shell\Open\Command]="C:\Path\OpenProgram.exe"

... and "C:\Path\OpenProgram.exe" is the full pathname to the desired default opener.

  • 1
    But that key doesn't exist. I'm not interested in creating it, I just want to know why there is an Open command even if the key doesn't exist. – Donald Duck Sep 29 '17 at 14:52
  • OK, so the key is somewhere else in the Win10 registry. I doubt anyone here can answer why, other than: it's cruft. You are looking for meaning in a gigantic dinosaur of a registry system. I assumed you would want to set that key's value wherever it was, and tried to help, but apparently you "just want to know why", and I got downvoted for the attempt to help you. Yay. – Joe Marfice Sep 29 '17 at 20:58
  • @​JoeMarfice I want to know where if the key is somewhere and in that case where it is. I'm not interested in creating it. I'm not the one who downvoted you, I appreciate that you were trying to help, but unfortunately your answer doesn't answer my question. – Donald Duck Sep 30 '17 at 10:13
  • You keep changing what you claim to want answered. I've actually already tried to answer this, but you said you didn't want to know that, when I did. Your aversion to creating a key (really, giving it instantiation; it already "exists" as a potential in Windows) is odd, but not my problem. I give up. – Joe Marfice Oct 2 '17 at 4:32

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.