3

I have Firefox 3.6 installed on my OS X (10.6) box. I would like to open an URL in the running Firefox instance (in a new tab or window, no matter) from the command line. I tried several ways, neither switches -new-tab, -new-window, -url, or none helped me. I always get the A copy of Firefox is already open. Only one copy of Firefox can be open at a time. error message.

1
  • The exact same thing is happening for me with the same setup.
    – Toby
    Feb 26, 2010 at 16:32

2 Answers 2

8

running

open http://www.superuser.com

from the command line will (at least for me) open a new tab to superuser.com in firefox (which is my default browser)

4
  • 7
    open -a FireFox http://superuser.com if you have a different default browser
    – cobbal
    Feb 26, 2010 at 17:16
  • 1
    @cobbal, though it will work whatever case you use, Firefox really just needs one uppercase F... :-)
    – Arjan
    Feb 27, 2010 at 10:22
  • Indeed, I think I've been using too much Objective-C, where everything is camelCased
    – cobbal
    Feb 28, 2010 at 1:54
  • 1
    @cobbal, bad ExCuse, not EveryThing is CamelCased. ;-)
    – Arjan
    Mar 2, 2010 at 8:24
0

Sounds like a bug in FireFox, since the mozilla website clearly states that for opening a website (from command line) under OS-X should be:

firefox -url www.google.com

The -url can be omitted, and the -new-tab switch added to force a new tab.

2
  • I just tried it under windows and "firefox.exe www.google.com" opens google in a new tab, in a running browser.
    – R-D
    Feb 26, 2010 at 20:17
  • 1
    Yes, I know it should work the way you mentioned, but it doesn't for some reason.
    – viam0Zah
    Mar 1, 2010 at 14:49

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.