I have a windows 10 desktop and I am remoting to my windows-10 notebook. Both are in my office, separated by a switch connected at 1gbps. I've edited the .rdp file and tried all options disabling features etc. No luck solving problem.

Essentially, if I reboot the notebook and remote desktop into it (full screen on my right monitor), mouse and keyboard work full speed. I can open my outlook 2013 and move the mouse over my inbox email rows and the highlighted row tracks perfectly with the mouse. I can open notepad and start typing fast and everything appears instantly.

After some duration, 10mins?, it degrades and I have random delays/lags like every second or two. Then, as I move my mouse over my inbox, the highlighted row starts to track my mouse, but then pauses, and a second later jumps down to where my mouse is. If I type into notepad, I visibly see random pauses in the keystrokes showing up within notepad.

I've disabled every app from startup not needed by the notebook. I've tried not running full screen, lower resolutions, lower colors, less features, etc with no luck.

It works perfectly, then after some time, it's starts that painful lag, and my only option is to reboot the notebook. Closing remote desktop and starting a new connection doesn't make the lag go away. The network adapter is still reporting 1gbps when the lag starts.

This is a new windows-10 notebook (lenovo P50). My prior lenovo notebook running windows 7 did not have this issue from the same desktop.

There is no anti-virus software installed.

What other things can I do to troubleshoot why this is happening?

  • I have the same problem, conneting to Win10 laptop from Win10 destkop. Or from Win8.1 laptop. Wired Gigabit connection. Feb 10, 2020 at 5:07

7 Answers 7


I have experienced a similar problem. I have a Remote Desktop Connection from a Win7 client to a Surface Pro 3 (SPro3) running Win 10 anniversary OS.

(NOTE Prior to the anniversary update I had sleep options which are no longer available - running powercfg /a from an elevated CMD window shows that sleep in not supported with the current firmware version).

I have the SPro3 configured to turn off the display after 15 min (I assume this also invokes some type of sleep mode). As long as the display on the SPro3 is ON the keystroke and mouse operations from the client to the SPro3 respond in a reasonable fashion. When the display on the SPro3 turns OFF response fro keystrokes and mouse movements are delayed slightly. Touching the SPro3 screen turning the display ON resolves the problem until the display is turned OFF again. I have also noticed when the display is turned OFF on the SPro3 running the task manager from the client the CPU activity is about 12% to 15% compared to 1% to 2% when the display is ON.

I should further note in the same configuration with the SPro3 running Win 8.1 and sleep properly configured (this took a while to configure and my notes are not clear) this problem didn't exist.

  • 3
    Thank You!!!! I never would have thought to check that but sure enough, I reached over, touched the screen to wake it up, and now all my remote desktop key/mouse issues delays are gone . Once it goes back to sleep, my remote desktop window starts having issues again. I hope MS fixes this. Otherwise I will have to waste time to write a stupid task bar utility to monitor keystrokes and wake the monitor back up.
    – happyfirst
    Oct 27, 2016 at 20:34
  • After wasting all day trying to troubleshoot this, I finally came across this page and sure enough, that solved it. 5 years later and this bug still exists. Mind blowing! Mar 8, 2021 at 20:08

This is also present on Intel NUC with Windows 10. Try setting Put display to sleep after to Never in "Power & Sleep settings".

enter image description here

  • This is a comment and not an answer. You do not yet have the reputation necessary to post comments on others questions or answers. Interact with the site a bit and you'll seen get there, though. Feb 28, 2017 at 19:51
  • This solution also worked for a Windows guest on a NUC. Go figure...
    – Origin
    Oct 8, 2018 at 9:27

@RichardH's answer worked for me too, but I like to keep my laptop lid closed while I'm remoted into it.

I found that running Chrome Remote Desktop (CRD) alongside RDP fixed the issue for me too. After installing CRD on the remote laptop and the local desktop, connect to the remote laptop using CRD so that the login screen shows. You don't need to login, just keep the CRD window open (not minimized). Then you can connect normally with Windows RDP and lag should not be present.

I also noticed about a 3% increase in the "System" process CPU usage when the lid was open but turned off compared to when it was open and on.

This only started for me after installing the Anniversary Update.


My work computer is a NUC and this issue was driving me insane, since I often work from home over RDP. As a couple of other people mentioned, preventing Windows from putting the monitors to sleep fixed my slow RDP issue. However, I had to make a couple other changes as well for this solution to really work for me.

First, I can't leave my work computer unlocked indefinitely if I forget to lock it manually. It used to lock automatically when the displays turned off, but no more. In order to get it to auto-lock again, I had to enable a screen saver (I'm using screen saver "None") and check the box for "On resume, display logon screen". I'm not actually sure how to navigate to the screen saver settings in the current version of Windows 10, but typing "screen saver" in the start menu brought me to it.

Second, when the computer is locked, whether manually or automatically, it will turn off the displays eventually regardless of the power setting. To prevent that, I followed the instruction on this page https://www.windowscentral.com/how-extend-lock-screen-timeout-display-turn-windows-10

  1. Use the Windows key + R keyboard shortcut to open the Run command, type regedit, and click OK to open the registry.
  2. Browse the following path: HKEYLOCAL_MACHINE\SYSTEM\CurrentControlSet\Control\Power\PowerSettings\7516b95f-f776-4464-8c53-06167f40cc99\8EC4B3A5-6868-48c2-BE75-4F3044BE88A7
  3. On the right side, double-click the Attributes DWORD.
  4. Change the value from 1 to 2.
  5. Use the Windows key + X keyboard shortcut to open the Power User menu and select Power Options.
  6. Click the Change plan settings link for the selected plan.
  7. Click the Change advanced power settings link.
  8. On Advanced settings, scroll down and expand the Display settings.
  9. You should now see the Console lock display off timeout option, double-click to expand.
  10. Change the default time of 1 minute to the time you want, in minutes (I used 71582788)

One thing I found was that physically powering off the monitors had no effect on my RDP performance, so I can turn them off before I leave the office and it doesn't cause problems with remoting in.


I ran into this as well with a Intel i5-6500 based machine. Skylake CPU. And the trick to keep the monitor awake fixed it.

Since it's happening when the monitor sleeps, I was suspicious of the video driver being the cause. Maybe it's some kind of power management. It turns out you can run an older driver from the 4xxx series and the problem is gone. This is what Windows Update provides as of 10/2018 for this HP system, and what HP offers as a download (ver 4849). I had installed a newer driver direct from Intel.


This worked for me. For me, I didn't have as similar as a problem of you; it was lagging from the beginning in the first place. However, you could give this a try and see if it works for you. Go to task manager and set the priority to high. To do this:

  1. Go to details tab on Task Manager (Ctrl + Shift + Esc).
  2. Find "remoting_host.exe" There may be two of them with PIDs 5704 and 4376.
  3. Right click on both of them and on "Set CPU priority", set it to "High".

After a computer restart, it might not save the priority, which will return back to normal. If you wish to save the priority, you can use this software: https://www.prnwatch.com/prio/ It will add a context item in Task Manager when you right click on a process to "Save priority"

Note that changing system process priorities can make your system unstable. I haven't had a problem so far, though.


this turned out to be fixed on my windows 10 computer with chrome remote desktop by disabling the power management power saving feature for the wifi wireless adapter in device manager.

(i tested disabling all power saving features in control panel "power options" first and none of those adjustments helped.)


Your Answer

By clicking “Post Your Answer”, you agree to our terms of service and acknowledge that you have read and understand our privacy policy and code of conduct.

Not the answer you're looking for? Browse other questions tagged or ask your own question.