highlight a word and three-finger-tap on trackpad used to bring up a dictionary entry. But in macOS 10.11 and current Firefox this feature is broken.

Feature is enabled in System Preferences > Trackpad:


Works fine in other programs but not in Firefox

NOTE: Question originally asked here. Can not answer there due to insufficient points. So re-asking and answering here.


Firefox has a history of this feature being broken:

With both tickets being fixed as of oct 2016, this feature is working as expected in macOS 10.11 + 10.12. Make sure to enable it in System Preferences > Trackpad > Look up & data detectors.

| improve this answer | |

I use macOS 10.12.3 and Firefox 51.0.1 on a MBP with force touch trackpad.

Initially, I was using the dic lookup with a strong single click. However, the dic lookup was not working in Firefox even though it worked flawlessly in other apps. When I changed to use a three finger click instead of a strong single click it also worked in Firefox.

So I conclude that Firefox can't handle the strong single click (available with force touch trackpads).

| improve this answer | |

You forgot to mention your versions.

Here i have: Firefox 51.0.1 (64-bit) and OSX 10.12.3

it works just fine. Heck even if i tap on the about dialog text it will work.

enter image description here

My guess: you have an extension that capture some gestures. Try disabling it. If it doesn't work, call up Apple support.

As a work-around, you can select the work, right click and the very first option will always be "Look up some work". Which is even better than three finger tap because you can search definition for two words, such as "pop up".

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.