0

In Excel, the workbook calculation of formula is attached to each file, set by File -> Options -> Formulas -> Calculation options -> Workbook Calculation.

However, if Excel is opened directly, not by opening a file, a "Book1" will be opened and the setting is always "automatic". How could I make the default setting "manual"?

I found these instructions below:

Changing the default is done in the following way:

Create a new Excel document in which all default settings are set e.g. fonts, styles, logo, header, footer, ...

Save the file as book.xlt in the excel system startup folder
File > Save as
Browse to the Excel system startup folder
File name : book
Save as : Template (*.xlt)

Note:Excel searches the following directories to open all files in it when it is started

'User Excel Startup Folder'
c:\winnt\Profiles\\Application Data\Microsoft\excel\xlstart
c:\Documents and Settings\\Application Data\Microsoft\excel\xlstart
'System Excel Startup Folder'
c:\Program Files\Microsoft Office\office\xlstart
'Alternate Startup Folder'

However it seems it's talking about Windows NT. My OS is Windows 7.

1

Do as Sir Adelaide states above, in his answer, but try saving the new workbook as book.xltx (or .xltm if you want to include macros) in the XLStart folder. Restart Excel and see if it does what you want it to do.

The XLSTART folder should be in a location similar to this for 2010: C:\Users\<username>\AppData\Roaming\Microsoft\Excel\XLSTART

Where: <username> is the name of your profile on the machine.

  • Excellent. Glad you're up and running. – Jurro Aug 31 '17 at 1:08
0

Open a new blank workbook.

Change the setting to manual calculation.

Save As, select file type "Excel Template (*.xltx)". This will change your explorer location to somewhere near where we want to be.

Don't save yet, but in the 'breadcrumbs' at the top of the Save As explorer window click on 'Microsoft', then browse into the folder 'Excel>XLSTART'. You'll be somewhere like "C:\Users\Athos\AppData\Roaming\Microsoft\Excel\XLSTART"

Now you are in the right spot, but don't save yet. Change the file type back to "Excel Workbook (*.xlsx)" and save with any file name.

  • it doesn't work on my PC. – athos Oct 25 '16 at 3:17
  • Ok, well I came up with those instructions using a Win 7 Excel 2010 computer. Worked for me. Is there anything else in the AppData\Roaming\Microsoft\Excel\XLSTART folder? Mine was empty but forseeably other spreadsheets there could provide other defaults. – Sir Adelaide Oct 25 '16 at 6:51

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.