6

A couple of months ago, Google Maps on the Chrome browser lost the "Earth" view mode. I can no longer get the 3D view or zoom out to see the real time cloud cover. All it has is the 'satellite' view. At first I thought this was a bug they would eventually fix, but nothing so far.

Google maps on Firefox still has the earth view feature for some reason.

  • Earth view with 3D is working again with newer version of Chrome. (Version 55.0.2883.87 m (64-bit)) – P a u l Jan 16 '17 at 21:17
  • Earth mode is now here in case you are searching for it. – Michael S. Dec 21 '17 at 6:33
  • This is off-topic for Super User as it is referring to the web app, Google Maps. – Burgi Dec 21 '17 at 9:02
  • I am missing the 3000 points to vote for migrate. Maybe at a later point in time. – Michael S. Dec 21 '17 at 10:33
  • Why is this tagged [google-earth]? The question appears to only be about Google Maps? – I say Reinstate Monica Dec 24 '17 at 17:56
3

It is still there, but you have to ensure that "Hardware Acceleration" is Enabled inside Chrome settings:

chrome://settings

  • click Show Advanced Settings
  • scroll down to the "System" section and check "use hardware acceleration when available"

Then, restart chrome and you should now have the "Earth" option

  • Didn't work. It was already set .. I unset it and reset, no difference. – P a u l Oct 25 '16 at 5:02
  • @Paul is Chrome up-to-date? If I remove the option, "Earth" feature is removed and replaced by Satellite." Do you have WebGL enabled inside of chrome://flags ? Have you tried reinstalling chrome? – Mike Diglio Oct 25 '16 at 14:17
  • I enabled webgl, no difference. I'm using Version 52.0.2743.82 m (64-bit). Like I said, this started after an update a few months ago. It had been working for years! Another bug started at that time, my start page on opening chrome, google adv. search, loads as only dark rectangles? I have to go to another site, not google, and then back to the start page to load it correctly. The google forums have been useless on this issue. – P a u l Oct 25 '16 at 19:10
2

The problem seems to be tied to WebGL being disabled in Chrome ... the graphics card may be "blacklisted". Try this:

  1. Type this into address bar: chrome://flags
  2. Enable 'Override software rendering list' ... should be at the top.
  3. Re-launch Chrome.

Worked for me...hope it helps.

  • +1, Hardware acceleration was already enabled, this is the solution that worked for me. – Kevin Wiskia Feb 2 '18 at 17:41
  • Did not suffice in my case. This worked finally : maps.google.com/?force=clear – peterd Dec 10 '18 at 4:26
1

I have the same problem. Window 10, Chrome 55, Intel HD4000/Radeon HD7600M. No earth mode in Google Map only Satelite when I open from Chreom (and Opera) but no problem at all when I open from Firefox, MS Edge or even oldie IE. It's very weird because when I boot from another partition (on my old HDD) with the same drivers and softwares, it works fine . I tried all suggestions but still doesn't work.

Just minute ago I found this suggestion and it solved my problem. Just enable "Override software rendering list" in Chrome.

https://productforums.google.com/d/msg/maps/I8snLYto720/R1DLH-T5BwAJ

Not the answer you're looking for? Browse other questions tagged or ask your own question.