1

I have a virtual machine (VirtualBox, Vagrant base box hashicorp/precise64) running on a Windows 7 host. I have installed NodeJS v4.4.4.

It seems I'm having problems with some network connections, in particular my company's internal NPM registry which I've configured with:

npm config set strict-ssl false
npm config set registry https://my.company.corp/npm-registry/

Whenever I run npm install some-package I get a message saying that the shasum is incorrect, after digging into the debug log I can see this is due to a ECONNRESET error and only part of the file was downloaded.

The NPM log shows the full URL to the downloaded archive, I attempted to download the same file with wget and a similar error occured wget https://my.company.corp/npm-registry/some-package/-/some-package_0.0.1.tgz, error mentions connection reset by peer.

  • The same file can be downloaded via curl.
  • npm install some-package works fine from the Windows host
  • The same Vagrant setup works fine on any of our OSX machines
  • I have tried using a newer version of Ubuntu in VirtualBox without Vagrant, same problems

Unfortunately I can't share the URL to the company's registry, although you wouldn't be able to connect to it without VPN access anyway. Hopefully I've given enough information to get some pointers.

1

I was able to solve the problem by simply downgrading VirtualBox. I was originally using v5.1.8 and downgraded to v5.0.10.

1

I had similar issues.

I have a Windows 7 guest Virtual Machine running in VirtualBox on a OSX host.

I was using VirtualBox 5.1.8.

Running the following javascript with node.js resulted in the ECONNRESET error:

var request = require('request');
request('http://google.com', function(err, response) {} );

Downgrading VirtualBox to 5.1.6 fixed the networking issues.

Your Answer

By clicking "Post Your Answer", you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.