2

I recently switched to linux (mint 18 KDE) after the windows install on my became corrupted (read: I cannot go back into windows to fix this issue). The wifi refuses to work, sudo rfkill list confirming that phy0: Wireless LAN is Hard blocked: yes. My computer has a wifi key, fn-f3, but this does nothing.

is there another way to enable the wifi card? on windows I had no issues (until the whole thing failed).

the laptop is an Acer Aspire ES1-521 (i don't know if they make other versions, but it uses an AMD A8)

I have no wired connection where I am, so I cannot connect the laptop to the internet to fix issue. I have another computer that I can download stuff to and transfer via USB.

I am moderately familiar with computers in general, and linux.

  • Which wifi hardware is it using? Enter lspci or lsusb from a terminal window to see which PCI resp. USB hardware you have. What do the logs say directly after boot, when it tries to load the drivers? Logs are usually in /var/log/syslog, so do less /var/log/syslog as root, or sudo less /var/log/syslog to read it. Look for anything that is about your particular wifi card. – dirkt Oct 26 '16 at 4:48
  • Can you unblock the card using rfkill, e.g. sudo rfkill unblock wlan, and after that sudo rfkill list shows it's not blocked anymore? – dirkt Oct 26 '16 at 4:50
  • @dirkt sudo rfkill unblock wlan removed the soft block, but not the hard block – YourGamerMom Oct 26 '16 at 15:20
  • Then it's some kind of driver problem, either for the wifi card, or for the hardware that blocks wireless. Especially the latter is always "fun" to debug, even for experienced Linux users, because each laptop is different, and while Windows is supported with special drivers etc., Linux isn't ... Definitely look at the logs, put them up somewhere (pastebin, ...) and post a link if you can't make sense of them. – dirkt Oct 26 '16 at 16:04
2

I solved this issue by adding

blacklist acer-wmi

to my etc/modprobe.d/blacklist.conf. Then a quick reboot and everything was up and running!

| improve this answer | |
  • Can you explain why this works and/or how you arrived at this solution? It isn't obvious from the question. Thanks. – fixer1234 Oct 26 '16 at 21:23
  • 1
    @fixer1234 arrived at this solution from response #7 in this forum thread that I found while researching my problem. I guessed that if blacklist wmi didnt work maybe blacklist acer-wmi would since I have an acer PC – YourGamerMom Oct 27 '16 at 1:37
  • That's... an INCREDIBLY lucky guess. Are you sure you just guessed it? – Adam Wykes Nov 2 '16 at 17:37
  • 1
    @adam I also tried acer_wmi acer wmi, and atheros-wmi (my wifi card is an atheros one) but acer-wmi worked so I left it – YourGamerMom Nov 2 '16 at 18:52
  • did not work for me :( – anaval Nov 27 '19 at 15:15
-1

OK! l Also have this same notebook laptop..... .....same problem I fixed it 100 % working wifi....

STAP 1: DOWNLODE THIS ZIP https://www.atheros-drivers.com/download-driver-nr-301-for-atheros-AR5BWB222-and-Windows8.html

STAP 2: extract zip file in specific location.

STAP 3: 1.Open the "Run" dialog box by pressing and holding the Windows key, then press the R key ("Run"). 2.Type devmgmt.msc

STAP 4: locate " OTHER DEVICES > network controller > right click > update driver software > browse my computer for driver software > browse the specified folder location that you extracted your zip file (include subfolders) > NEXT.....

| improve this answer | |
  • 1
    You should correct the numerous spelling and formatting problems in this answer. If you as the author do that I will reverse my downvote. (i.e. STAP vs Step). – Ramhound Jan 20 '17 at 18:50

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.