0

My windows 7 ultimate recently has started pushing me back to the logon screen on startup. Even tho this is my private machine and it has no administrator password. Somehow every now and then it reverts to having me to either click the user picture before getting to the desktop or when I set the password (since I thought this might help) it also asks the password. When I go to control userpasswords2, the "Users must enter a user name and password to use this computer" is unchecked... and yet it still behaves as if it was selected (randomly, like it gets that idea, and sticks with it until I turn it off again). I also tried to add the default password line to the regedit and it still didn't help.

It's really annoying to me because I need this machine to be able to auto logon and not require me to click or enter password every time. Please help. I really need a way to force auto logon on my machine and make it stay that way.

PS. I have tested for malware and viruses, the machine is clean.

0

I originally quoted from TechNet about the setting in netplwiz, however I notice in your question you state you've already tried that.

You could try Autologon instead.

Turns out that @Borg777 had Teamviewer enabled at startup which was causing the setting to be reset. I have a feeling it may be a specific setting within Teamviewer, however disabling at startup resolves the issue for now.

  • Thanks for the quick reply! (And edit to it). Was already trying to get back to you. Yes sadly when I go the netplwiz way, it still forgets the setting and reverts back to requiring password/clicking on logon till I either redo the procedure or... weirdly, do a few restarts. So I'm thinking maybe there's some sort of a conflict? I will check the autologon program, thanks for the link... will report back. – Borg777 Oct 26 '16 at 13:18
  • OK, so I have set the password for my account again (Because autologon doesn't support NULL passes) and enabled it. Will test this for a few days to make sure it isn't overridden by something triggering this weird system behavior and if it sticks, will mark this as an answer. Thanks again for the help, VA. – Borg777 Oct 26 '16 at 13:26
  • ... And it doesn't work already :( I did this to simulate normal use cycle I do: shut down the system -> power on (works fine) -> sleep -> wake up (works fine) -> turn on Teamviewer (since I'm suspecting it might be related?) -> access my other machine -> exit -> restart... and the autologon is broken again :( it required me to enter password at the logon screen to get to desktop again. – Borg777 Oct 26 '16 at 13:37
  • I have a feeling it may be a Teamviewer setting. Do you have unattended access set up? – Virtual Anomaly Oct 26 '16 at 13:41
  • Back. I have set Teamviewer (TV) not to start with the system by unchecking Options->General->Start Teamviewer with Windows. I did a few restart/shutdown/sleep/wakeup cycles. Everything worked fine. Even when turning TV on manually and accessing remote machines this didn't affect logon. Then I set TV back to starting with Windows, after 2 restart/test cycles problem came back. So I set TV not to start with windows, it's resolved. Bottom line, yes, I believe it's TeamViewer causing this logon conflict. – Borg777 Oct 26 '16 at 14:29

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.