13

I'm running Windows 10 and I use the Alt+Shift+L shortcut, which brings up this annoying dialog:

Synaptics TouchPad Driver Diagnostics dialog

I've already run the registry key fix as follows, and reset the computer afterward:

reg add HKEY_LOCAL_MACHINE\SYSTEM\CurrentControlSet\services\SynTP\Parameters\Debug /v DumpKernel /d 00000000 /t REG_DWORD /f

Is there a way to change the hotkey assignment, or somehow disable the diagnostics service?

4
  • 3
    for me it is the shortcut for Resharper find active document in solution explorer
    – Iman
    Apr 27, 2017 at 5:53
  • 1
    @ImanAbidi you can also use the Visual Studio shortcut of CTRL + [, s to find the active document stackoverflow.com/a/14224290/8595398
    – Matthew
    Feb 5, 2018 at 6:16
  • @trejder What's your motivation for changing the question title? You literally changed it from a question to a statement
    – nikodaemus
    Sep 6, 2018 at 12:58
  • My motivation is to make question's titles as short as possible. I don't have a reference handy right now, but I read in some place (at Stack Exchange probably) that we should: (a) have questions titled as short as possible and (b) avoid question-like "introductions", including "What is", "How to" etc., because they are not bringing any value (no additional information, context remains unchanged), but makes the titles very long. This is question, right, so every one knows that you're asking about something and you don't have to actually ask in the title. Limit yourself to the context only.
    – trejder
    Sep 7, 2018 at 13:33

5 Answers 5

6

After updating to Driver Version 19.0.17.115 (also shows Firmware Version 1.5), the registry fix now works.

1

Providing updated answer since previous ones are two years old and a bit out-of-date.

As of September 2018 it is no longer possible to install drivers for TouchPad (or other Synaptics hardware) directly from Synaptics' website. You have to search the Internet for your manufacturer's OEM driver that is tailored exactly to your computer / hardware.

For example, for ThinkPads you have to either use Lenovo website (Synaptics ThinkPad UltraNav Driver 19.3.4.214 for Windows 10) or Softpedia (Lenovo ThinkPad T550 UltraNav Synaptics Driver 19.0.17.115 for Windows 10). Or simply google it (ThinkPad Synaptics Driver for Windows 10).

After driver update and Windows restart you must set Windows Registry entry as in OP's question.

There are rumors that even with updated driver and Windows Registry entry correctly made, this nasty nag screen still appears. In this case, blocking automatic drivers installation in Windows 10 may be the only way.

0

Have you tryed AutoHotkey? you can simply disable a Keycombination or remap it so you can e.g. make Ctrl+Win+T to that window while blocking the Alt+Shift+L combination

1
  • 3
    This isn't an acceptable solution for me
    – nikodaemus
    Nov 3, 2016 at 13:42
0

Disabling SynTPEnhService service allowed me to stop seeing these prompts, while keeping touchpad's functionality. I made sure that the service also does not start automatically on startup.

Neither modifying the registry or updating drivers seemed to have worked for me.

0

After updating to version 19.2.17.70 I no longer had this issue. No registry fix was required.

I had to search for this update myself on my laptop manufacturer's website. Trying to update the driver from the device manager didn't work.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .