15

For some reason when I opened chrome this morning I noticed that the entire UI has been scaled up slightly. Everything (buttons, text, webpages, etc.) is about ~10% larger than it used to be. This is really annoying since now less fits on my screen (particularly now my bookmarks bar doesn't fit as many bookmarks).

I can't find any kind of UI DPI scaling option in the settings. How can I change it back to what it used to be?


Notes:

  • This isn't a problem in the Windows DPI scaling settings since this didn't happen with any other programs.
  • I know how to zoom in and out of webpages, but that's definitely not the problem as the entire UI is scaled up, not just the webpage.
4
  • Have you checked if there is DPI scaling configured in the application compatibility settings? Right-click on the Chrome shortcut on your desktop, select Properties, open the Compatibility tab, if checked, uncheck the “Disable display scaling on high DPI settings”. Restart Chrome. Oct 26, 2016 at 18:24
  • When was the last time your Chrome version was updated? i.e.: was an update applied since you last used it? Oct 26, 2016 at 18:51
  • @Ƭᴇcʜιᴇ007 I'm not aware of one, but it's quite possible.
    – PGmath
    Oct 26, 2016 at 18:51
  • I mention it because when things "magically change" about Chrome, those automatic updates are usually the cause of unexpected changes. Plus the current version you're on and when it was updated last is good info to supply when asking for help with these things in Chrome. :) Oct 26, 2016 at 19:03

3 Answers 3

19

With the Chrome 54 update they made it so Chrome can detect the DPI setting on your computer so that the web browser will be scaled accordingly.

Google Chrome didn’t used to pay attention to your Windows DPI setting. Now it does, and that’s the root cause of the large interface issue.

If you have the DPI scaling set to 125% or greater on your Windows computer, then the Chrome browser will scale differently depending on that setting.

Option #1

Have Windows specifically tell the Chrome program not to do DPI scaling by:

Right-click the Chrome icon > Properties > Compatibility > and CHECK "Disable display scaling on high DPI settings"

enter image description here

Option #2 (Seems to be most successful)

The obvious fix is to just set your computer’s DPI scaling back to 100%. That will make Chrome appear how it used to but everything else will be smaller, so it’s not a very good fix.

Just type “dpi” into your Windows search bar and open the top result, “Make text and other items appear larger and smaller” (at least that’s how it is on Windows 7).

Option #3

Right-click on the Google Chrome shortcut or start menu icon and select >properties > shortcut tab

Enter the following code at the end of the text in the Target field:

/high-dpi-support=1 /force-device-scale-factor=1

Make sure there’s a blank space between the .exe” part and the first forward slash.

Hit Apply and then restart Chrome.

If the scaling isn’t back to normal, make sure to launch Chrome from the location specified above. If Chrome is on your taskbar, don't forget to unpin Chrome and repin it. This isn't a permanent fix anyway because other links to Chrome (like hyperlinks in PDFs) can trigger the larger UI as well.

7
  • I tried your first option and it did nothing (I presume it's supposed to say "Disable display scaling..."). And in Windows 10 I don't see a "Target" field under properties.
    – PGmath
    Oct 26, 2016 at 19:08
  • @PGmath you can look at the screenshot I added. I'm on Windows 7 so there may be some differences between the two. I also added a missed step for Properties for option #3. The target field is located under the Shortcut tab in the Properties dialog box.
    – DrZoo
    Oct 26, 2016 at 19:16
  • OK, I was looking at the actual chrome.exe file not the shortcut. I tried option 3 with the shortcut and it worked, thanks!
    – PGmath
    Oct 26, 2016 at 19:20
  • 2
    Option #1 "Disable display scaling on high DPI settings" is a misleading and irrelevant setting. It is really "Disable DPI virtualization for the application", which can fix some blurry text problem for legacy programs, but has no effect on programs with high-DPI support such as Chrome.
    – jingyu9575
    Oct 27, 2016 at 2:50
  • 1
    #3 worked for me.
    – Kozuch
    Nov 5, 2016 at 21:13
1

I'm using Google Chrome Version 62.0.3202.94 (Official Build) (64-bit) on Ubuntu and I see under "Settings | Appearance" that there is a "Page Zoom" setting that you can use to customize the scaling in Chrome. I'm sure it's there in the Windows and Mac versions too.

I have mine set to 125% because I have a laptop with a 4k display and the normal zoom factor is too small in Chrome, though the rest of the OS (Ubuntu 17.10) is fine.

Page Zoom Setting

1
  • 2
    This only affects the page scaling, not the whole browser UI. For that, on Linux, one would need to start the browser with --force-device-scale-factor=1.25 command line option - see superuser.com/a/1120078/289345
    – stsloth
    Oct 11, 2019 at 17:20
0

I had similar problems and while the scaling override fixed it somewhat, something still looked off. I was also seeing a seemingly unrelated issue, a greyed out maximize button, which led me to another solution.

Chrome Maximize button greyed out and not working

This may be the case for you or not, but it seems that Chrome now also detects whether your device is touch-enabled and if so, displays certain top bar elements larger.

If you find this setting doing more harm than good, then go ahead and disable Touch UI via the Touch UI Layout flag.

  1. Navigate to chrome://flags in your address bar
  2. Search Touch UI Layout
  3. Set to disabled
  4. Reload Chrome as prompted

Your UI sizing will now hopefully make more sense.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.