8

I am using iTerm in Mac OS X. When I run screen, the terminal is resized and I get the message

Aborted because of window size change.

However, screen is still running.

How do I get it to stop resizing my terminal?

11

This will fix the problem: Bookmarks –> Manage Profiles –> Terminal Profiles –> Default

check "Disable session-initiated window resizing"

See also "iTerm resize the window itself when using screen".

  • Nice, this keeps me from having to figure out how the termcapinfo entry works. – Chas. Owens Mar 9 '10 at 16:13
  • Your solution helped me greatly. I'm using iTerm2 on Mac OS X Lion, and the path disable session-initiated window resizing was a little different for me: Profiles -> Edit Profiles ... -> Default -> Window -> Disable session-initiated window resizing. Thank you! – mkelley33 Jan 31 '12 at 20:11
  • @juanpablo Thank you for this one. That bugger was driving me nuts since I've been switching to neovim a couple of days ago. Upon starting nvim (NVIM v0.3.8) my iTerm2 (Build 3.3.2) window used to shrink in both width and height by one row and column which did not happen with e.g. Vim 8.1. Your solution fixed that issue for me! – Saucier Aug 22 at 14:14
2

Based on an Ubuntu forum post on problems with screen, I found that adding

termcapinfo xterm 'is=\E[r\E[m\E[2J\E[H\E[?7h\E[?1;4;6l'

fixes the problem, but I have yet to examine it to find out how.

  • 1
    Did you discover what this magical termcap incantation does? :) – Ether Mar 2 '12 at 23:18

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.