1

The problem is that I cannot print to a shared printer from 2 computers in our work network. So I'll cover a few things and maybe you can help me.

  1. Error code is 0x80004005
  2. The sharing computer is running windows 7
  3. The computers I can't print from are Windows 8.
  4. I can print from other computers to that printer, it's just those two computers that don't want to print
  5. I can see the sharing computer on network, but cannot connect to it, I get a "Invalid computer name" or a similar error, can't remember exactly the wording.
  6. Antivirus is not the problem, tried with it turned completely off.
  7. Network and device discovery is turned on
  8. Printer sharing is on.
  9. The computers that don't want to print have the exact the same settings as the computers that do want to print. I set them up myself.
  10. I CAN ping the sharing computer.
  11. Tried it both with admin and standart users.
  12. I can see both computers from the sharing computer.

So, any suggestions? :)

  • 2
    Can you access and shared directories on the computer which is hosting the printer by name? It sounds like it could be a NetBIOS naming issue. You could try acessing the printer using the IP of the host machine to narrow the problem down to an issue with the hosting machine or the network. – Alex Oct 27 '16 at 11:22
  • Like @Alex, I have had a few problems with accessing shared files and printers, but I have overcome them by using the IP addresses. A slight down-side is that I need to configure my intranet so that all computers with shares have fixed IP addresses. – AFH Oct 27 '16 at 11:29
  • If your network hardware doesn't broadcast NetBIOS names, many of the sharing features on Windows will have problems. Are you using a domain or workgroup? If your router supports it, you could allocate the same IP to a known machine based on MAC address. You can still DHCP assign an IP to machines with shares, just so long as it's always the same one. – Alex Oct 27 '16 at 11:31
  • AHHHH - Just saw your windows versions. Did you enable SMBv1 and SMBv2 on the windows 8 machine?support.microsoft.com/en-gb/kb/2696547 By default, Windows 8 runs a newer SMB version which doens't like talking to older versions. – Alex Oct 27 '16 at 11:32
  • Haven't checked the SMB yet. Will do! As for the name, I tried accessing it with both name and IP. From other computers, even running windows 10, I can do that just fine – Kelsier Oct 27 '16 at 11:35
0

As @alex suggested, I've enabled SMB on windows 8 computers. And the problem was solved! Thank god, this gave me so much frustration!

How to enable SMB you can find here : https://support.microsoft.com/en-us/kb/2696547

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.