2

My Firefox seems to be getting very laggy lately and this used to happen on my older computer when I was low on memory, however I checked and I have plenty of memory still available but it's still laggy, so I'm wondering do I perhaps have to increase the memory it's allowed to use?

By laggy I mean it has the same visual effect as lag, in that when you're interacting with the screen things "lag" / get stuck / appear slow - nothing to do with page load time.

I did a little digging and found this almost 12 year old thread; so I'm wondering does what is mentioned there still apply now?

Namely, by going to about:config in the address bar and then adding the configuration setting browser.cache.memory.capacity and giving it a value of the amount of memory it's allowed to use in Kb's?

If not, is there a way to do this?

  • if your cpu is slow there is no connection between heavy javascripts and memory usage. – Ipor Sircer Oct 27 '16 at 16:56
  • @IporSircer No, my CPU is not slow. – Brett Oct 27 '16 at 16:58
  • increasing the cache "memory" is just going to increase or decrease the amount of cache Firefox manages it will not actually increase or decrease the amount of system memory Firefox can use. Can you be more descriptive then "its still laggy", because "lag", is latency and has nothing to do with Firefox using system memory. – Ramhound Oct 27 '16 at 17:33
  • @Ramhound Ok, I updated my question. – Brett Oct 27 '16 at 18:08
  • 1
    use about:memory or addons.mozilla.org/en-US/firefox/addon/task-manager to see which addon uses most RAM. – magicandre1981 Oct 28 '16 at 14:52
1

The link in your question was from 12 years ago. Webpages in 2016 use a lot more memory than they did in 2004. To get rid of lagging and video stuttering in Firefox type about:config in the Firefox address bar and change the following preferences:

  • browser.cache.disk.enable true
  • browser.cache.disk.capacity 358400
  • browser.cache.disk.smart_size_cached_value 358400

This is all the browser cache that you need to improve Firefox's performance if you are watching standard definition videos, and adding more won't help unless you are watching high definition videos in Firefox.

  • I just checked and both browser.cache.disk.enable and browser.cache.memory.enable are both currently set to false. You should probably not in your answer that browser.cache.disk.enable needs to be set to true for this to work. – Brett Oct 28 '16 at 13:07
  • I'll see how I go with this. :) – Brett Oct 28 '16 at 14:17

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.