99

When you run more than six applications on Windows 7 and you press Alt + Tab, icons representing the first six applications and the desktop appear on the first row of the grid and you can cycle with Alt + Tab + Tab... through the six most-recently used windows the usual way, but the seventh and other less recently used windows don't follow the same rules.

Instead they get grouped together according to their application, but disregarding whether they were recently used or not. This new behavior is mentioned here.

I am very used to the old way of cycling and the new system is driving me crazy. I tend to have 20 or so windows open at one time and I frequently need to alt-tab to the seventh or eighth window on the stack, but it doesn't work the same any more.

How do I put back the old behavior, so that Alt + Tab + Tab + Tab ... goes through the whole list in most-recent to least-recent order?

4
  • Question is quite old now. But let me know if 1. Holding alt (any) and pressing tab - tab -tab ... and 2. alt + shift + [tab tab tab] (for backwards) work today with your machine. I am curious.
    – Anubhav
    Aug 18, 2014 at 7:49
  • Under System properties > Advanced > Performance options > Visual effects, I had adjusted for best performance I was getting grid of icons which is classic ALT+TAB behavior. So, I was curious.
    – Anubhav
    Aug 18, 2014 at 8:12
  • 1
    Let me know if that is not the classic grid. I think it is. Another thing, even then, 'Always on Top' applications get a special treatment.
    – Anubhav
    Aug 18, 2014 at 8:14
  • I think the broken link in the OP is moved to: devblogs.microsoft.com/oldnewthing/20080701-00/?p=21793
    – Ron Burk
    Mar 22, 2020 at 20:19

5 Answers 5

100

To restore the Windows XP Alt-Tab functionality simply launch regedit, add a DWORD named AltTabSettings to HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer and set its value to 1.

And here's a one-line PowerShell script which does the above:

Set-ItemProperty HKCU:\Software\Microsoft\Windows\CurrentVersion\Explorer AltTabSettings ([int]1)
11
  • 9
    It worked! Thanks, accepted. Is there a way to turn off the weird W7 ordering without turning off the nice W7 large alt-Tab preview icons etc? That is, can I keep the W7 alt-tab interface but with the XP ordering? Mar 4, 2010 at 19:16
  • 1
    Thanks. But why this happens? Why explorer forget to switch windows with Alt+Tab?
    – Isaac
    Oct 12, 2011 at 15:11
  • 13
    Paste reg add HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer /v AltTabSettings /t REG_DWORD /d 1 /f into the "Run" dialog if you're too lazy to use PowerShell like me. Jan 10, 2013 at 16:43
  • 5
    Not working. Do I need to do a restart? Jan 12, 2015 at 8:00
  • 2
    @AlikElzin-kilaka: In the current version of Windows 10, yes, this does appear to require a restart of Windows Explorer; rebooting the entire machine also works. Feb 20, 2019 at 19:38
48

Not sure about tab order but you can access the old Windows XP looking Alt-Tab like this:

  1. Hold down the left alt key

  2. Press and release the right alt key, keeping the left alt key held down

  3. Then, still keeping the left alt key held down, tab-tab-tab away to you heart's content...

alt text

Thanks to BlogSofts via The Road To Know Where

5
  • 6
    Nice! I didn't know it could do that! But it's a PITA that you have to hit the right Alt then the left Alt for this to work.
    – Hondalex
    Feb 26, 2010 at 22:55
  • You do get used to it after a while :)
    – Shevek
    Feb 27, 2010 at 7:57
  • 5
    Does anyone know how to make this the default behavior? I like that sooooo much better.
    – jimbo
    Sep 30, 2011 at 13:11
  • 6
    Add the "AltTabSettings" DWORD = 1 in "HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer" then it'll become the default behavior.
    – deddebme
    Apr 13, 2012 at 12:56
  • AMAZING! @Hondalex : also it makes it so you can't map this (in addition to the newer alt+tab) using the Steam Controller (without AHK magic at least) Apr 9, 2016 at 16:39
32

While I tried, liked and upvoted the accepted answer I found this setting by googling a bit more: Windows 7: bring back old Alt+Tab behavior, turn off Aero Peek

  1. Go to System Properties (right click Computer in an explorer window and choose properties)
  2. Click Advanced System Settings in the left panel
  3. You should be on the Advanced Tab, in the performance section, click Settings
  4. Uncheck Enable Aero Peek

It turns out you can keep the Windows 7 look, but avoid the odd flashing behaviour (lack of better words) that is Aero Peek.

7
  • 2
    Great tip! but I can't up-vote you because your answer doesn't seem to answer the original posters question.
    – jpierson
    May 13, 2011 at 14:07
  • 2
    I'm upvoting yours b/c you have added another piece to the puzzle of "making alt-tab work like it used to." Thanks - great nugget! Jul 12, 2011 at 22:00
  • This answer works best if you can't edit your registry directly (perhaps on a locked down machine)
    – Gary
    Aug 20, 2012 at 11:22
  • link doesn't work any more => always post the important piece from the remote site
    – sjngm
    Oct 13, 2015 at 8:47
  • 1
    @sjngm Thank you for notifying me. I copied the steps from the link and edited my answer.
    – johnny
    Oct 13, 2015 at 9:30
6

Try the combination Win + Tab. It uses the Aero interface, but give you a full cycle of your applications.

2
  • 1
    Interesting, I always hated the Win + Tab switcher but it does seem to keep stack ordering so maybe I'll have to start giving it a try once again.
    – jpierson
    May 13, 2011 at 14:10
  • @jpierson wow I never used it long enough to notice that. That's actually useful. Apr 9, 2016 at 16:40
0

In have just installed Windows 10 version 20H2. In addition to the registry key, you need to go to the settings (Windows + i) > System > Multitasking and set "Alt + tab" to the only setting not containing any "Edge" (in German Windows: "Nur Fenster öffnen", in English should be something like: "Open windows only"). Wrong German translation, BTW! Should be "Nur offene Fenster". ;-)

Not the answer you're looking for? Browse other questions tagged or ask your own question.