1

I have a situation like this:

Several years ago I've built a home NAS out of:

  • a Chenbro ES34069 case which came with a FSP180-ABA 180W 4 pin power adapter and a power distribution block inside the case.
  • 4 disks
  • an Atom+Ion based motherboard.
  • a Mageia linux

I do not have proof of power spike or irregularity from my provider.
I did not keep it on, but plugged into the power socket.

One day I have started it, it worked for a couple of hours. I have restarted it after some small OS update. It was the time to scan some disks. It started, passed one of the disks then started a second disk scan.

The progress was slow. It has 3TB and took about 5 minutes to scan 3%. Then the system shut down like a power off.

The power adapter has always had a fuss when in use and a few minutes after regular shutdown. This time too (also a led lightning).

I've started it again, the OS started the scan again, then at 3% of the disk scan - shutdown. Tried again, did the same.

It was late, I was tired, I've let it off, the power source looked as usual, the led on as it is plugged in.

Next day in the morning it was dead. It did not power up.

I have left it unplugged then did not come up after plugging it.

I took a second power adapter from a friend - same model of case and power adapter. The computer started, and tried to scan the disk.

It does the same: scans the disk and powers down at 3.1%-3.2%.

It seems obviously a hardware issue, I won't use my friend's adapter as I am afraid it will break.

What should I look for? The adapter seems broken by the hardware inside the box, the power distribution or the disk or the motherboard.

Has anybody a clue of what this might be the reason?

3
  • People are more likely to read your question/answer if you format it so it is not a wall of text. Please read Markdown help and edit your question to add paragraphs and bullet points ...
    – DavidPostill
    Oct 28, 2016 at 19:29
  • Sorry, is this better?
    – mike
    Oct 28, 2016 at 19:42
  • Much better :) ...
    – DavidPostill
    Oct 28, 2016 at 19:43

1 Answer 1

1

I think the most probable reason for such behaviour is a combination of two disagreeable factors:

  1. The power adapter may be overloaded (the total power consumption of the disks is near to the adapter's max permissible power or even slightly exceeds it)
  2. The second HDD (that was being scanned at the moment when the power faulted) is mechanically damaged - the magnetic head may touch the disk surface and hinder it in free rotation.

I would propose to try to use a more powerful adapter and change the questionable HDD.

5
  • If the power adapter is overloaded, it breaks? Also, why is it burned now, after leaving it off? Or wasn't it really shut down? What do you think?
    – mike
    Oct 28, 2016 at 20:00
  • Power adapters have electronic circuits to protect them from breaking in case of overloding, so usually they just turn off and after reapeated turn on they work fine - in case of normal load. But there may be unhappy conditions such that the protection fails to protect. When the consumtion does not exceed the limit too much, the proptection circuit may fail and the temperature may rise to an unappropriate value, if it has enought time.
    – m. vokhm
    Oct 28, 2016 at 20:09
  • Hmm. There is no obvious heating now. I've calculated, it needs about 150W, probably the psu should be over 200W in order to work. The psu is old, probably it was its time to break. I will need serious modding on the case in order to use a regular psu (read "ATX" family psu...).
    – mike
    Oct 28, 2016 at 20:14
  • Most of the experienced users I know (programmers, sysadmins etc) do believe that power supply must be at least twice as powerful as the consumed power in order to work normally.
    – m. vokhm
    Oct 28, 2016 at 20:20
  • Right, I have calculated the minimum. This setup worked for 7 years.
    – mike
    Oct 28, 2016 at 20:22

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .