I can't connect to WiFi, even though I have WiFi in my house. I've tried downloading new drivers and it just says:

Not connected - no connections available

I checked the device properties and it says:

Device install requested

Device PCI
\VEN_8086&DEV_0886&SUBSYS_13158086&REV_67\4&2387eb&0&00E1 requires further installation.

The network adapter is "Intel Centrino Wireless-N 6150".

I recently installed Linux Mint 18 as a dual boot with Windows 10, I could connect to wifi on linux, but windows wouldn't connect. So I uninstalled linux and nothing seemed to change. I also reset Windows and still nothing changed.

Please help.


If you have mentioned the model of your Wi-Fi module correctly then it is not supported under Windows 10. The latest version of Windows it supports is 8.1.

You can try downloading driver for Windows 8.1 and installing it in compatibility mode for 8.1. But it is not guaranteed that this option will work.

  • I already tried that, I think I'm just gonna take it to a it place and see what they can do, and if they cant figure it out, ill just get linux again – cracingbozo7 Oct 30 '16 at 6:08

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.