0

I'm trying to get a computer up and running again. It has an NF4U-AM2G mobo, AMD 64 x2 Athlon 4600 cpu, a DVD drive, a 250GB samsung IDE HDD, a 160GB Maxtor IDE HDD, and a 320GB Hitachi SATA HDD. For about a year and a half it ran Ubuntu 15.04, that ran find but was a bit quirk and difficult to deal with because the upgrade from 14.04 got botched. Eventually Ubuntu got erased and Windows 7 x64 Ultimate was installed for a while. One day Windows just stopped booting, and ever since nothing on any of the drives will boot at all.

I tried reinstalling windows, wouldn't boot. Tried installing literally 12 kinds of Linux, 4 kinds of BSD, and two custom made OS X installers, none of them boot post install. Here's the weird part: they all boot. Most of them installed, but there are recurring themes. Live optical discs and USB disks always boot, most Linux and Unix installers run all the way through, and so does the windows installer.

The 320GB drive always reports an error trying to configure package managers or when installing the bootloader, no matter the OS. The 165GB drive always installs perfectly fine, but hangs on "building DMI pool..." on every boot, and the 250GB drive always installs find but claims "no active partition" on every boot. Nothing is wrong with the drives or cables because they work perfectly find as storage drives with all formats when I boot up a live install from a flash drive, but if I try to install that same live copy to an internal drive via DD, the install copies fine, but the above issues always still happen.

Does anybody have any ideas? I've been working on this for weeks and have no idea what the issue is.

P.S. the one exception to these behaviours is ReactOS, which both boots live mode and installs fine, but on reboot it loads the kernel, drivers and bootloader from HDD (with ReactOS it doesn't matter which, they all act the same) but will immediately freeze afterward with the error "Unable to load system hive...". Might be a problem with the OS with this one, as its a nightly build, but still.

0

It sounds to me as though the southbridge/controller is causing the problem.

Since this isn't a daily system and you seem to have the time and inclination, I would suggest a hunnits clean install:

  • Reset BIOS to factory defaults / flash clean BIOS
  • Make BIOS changes to suit.
  • Write all your disks to zeros. (Personally I would bin the maxtor altogether)
  • Decide on your final install (Dual, treble, more boot)
  • Using a competent installer (Linux) cut your partition table. Formatting each to their end-use filesystem can help, and will stop winstaller being silly.
  • Install any windows flavours you require (remember these must be on a primary partition)
  • Install any *nix flavour(s), and a bootloader.

Where you fail in this will narrow down the cause.

6
  • Hunnits? Qu'est-ce que c'est? – Mathieu K. Oct 29 '16 at 7:49
  • Sorry. vernacular for "complete" (one hundred percent - hunnit) – user657451 Oct 29 '16 at 18:29
  • Well, I've run into a bit of an issue, it would seem that the BIOS update utility only supports flashing from Floppy, and I don't have an IDE cable of proper size for the one floppy drive I have. I have a USB one but that may very well fail. – Alison E.E. Oct 29 '16 at 19:42
  • •Reset BIOS-Complete. •Reflash Factory BIOs-Complete. •Wipe, Make new partition table for, and repartition main disks-Complete •Install needed Windows variant-Immediately noticed that the installer took 1/20th the time to boot than it has for the last 2 or 3 total years of reinstalls to this particular machine. – Alison E.E. Oct 29 '16 at 20:20
  • This worked perfectly. I don't know why I never thought of reflashing the BIOS in all this time but it seems to have completely fixed it. Windows is booting now and I'll be moving on to installing Linux in a moment. Thanks again! – Alison E.E. Oct 29 '16 at 20:52

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.