2

I have updated Geforce experience to version 3.0.7.34 and now am unable to stream quite a few of my games. I was using desktop capture feature for those, but now it seems to be gone.

Is there a way to enable shadowplay desktop capture, or this feature is toast and I should switch back to Geforce experience 2.0?

  • Could downvoter elaborate please, or is it related to hangover he's having after Friday. – Matas Vaitkevicius Oct 29 '16 at 13:57
  • There seems to be this incorrect assumption on many forums I've read that updating to the latest version will in all cases fix the problem, and that everyone experiencing this problem is being a noob about it. This is obviously inaccurate, and the fact that nv support appears to be ignoring most of these posts is not helping. I'm guessing the downvote was from someone who thought you didn't do it correctly. – aggregate1166877 Dec 17 '16 at 7:22
4

Update:

GeForce Experience 3.0 has an option for desktop capture, but you will still have to login:

Open in-game overlay -> Settings -> Privacy Control -> Desktop capture

https://streamable.com/csxqd


It's better to switch back to GeForce Experience 2.0 as described here

  1. Uninstall GFE 3.0
  2. Install GFE 2.0 http://us.download.nvidia.com/GFE/GFEClient/2.11.4.0/GeForce_Experience_v2.11.4.0.exe
  3. Delete setup.exe in C:\ProgramData\NVIDIA Corporation\GeForce Experience\Update\ to make sure it won't reinstall GFE 3.0
  4. Add a shortcut, since the ShadowPlay button is gone "C:\Program Files (x86)\NVIDIA Corporation\NVIDIA GeForce Experience\GFExperience.exe" -shadowplay
| improve this answer | |
  • Hi Ketho, thanks for the answer, could you please copy main content from the links into the answer - as links do die. Thanks. – Matas Vaitkevicius Nov 24 '16 at 22:39
2

I went with Ketho's answer, but for those want to try something else, registry hacking has worked for some. Many thanks to joshindaphils who posted the answer here; I've simply copy-pasted his answer below.

For whatever reason nVidia cripples shadowplay on laptops and does not allow the recording of your desktop.

To enable this feature copy the below text and use it to create a text file, name it what you wish, though with a .reg extension. Save it double click on it, afirm all popups, and bam you can now record your desktop:

Windows Registry Editor Version 5.00

[HKEY_CURRENT_USER\Software\NVIDIA Corporation\Global\ShadowPlay\NVSPCAPS]

"DwmEnabled"=hex:01,00,00,00
"DwmEnabledUser"=hex:01,00,00,00

Alternatively if you are familiar with regedit just add / edit these values.

| improve this answer | |
  • 1
    I tried this and it didn't work for some reason (both with and without a reboot), had experience version 3.3.x on a 765m – user2813274 Feb 22 '17 at 15:39
  • Ketho's answer worked for a different setup of mine using 765m; install latest drivers, uninstall GFE3, install GFE2, and then delete the setup to prevent automatic updates. – aggregate1166877 Mar 14 '17 at 21:07
0

You'll need to check the sharing privacy setting to determine whether desktop capture is enabled.

Open up GeForce Experience, go to Settings and check the Share feature in the General tab. Make sure it's turned on and note the keybinding to access settings. Press this keybinding to start up the Share overlay.

Once in the Share overlay, click the settings icon and scroll down to Privacy Control. This is actually the desktop capture setting. Set it to Yes and it should work.

Click here for a screenshot of the setting.

| improve this answer | |
  • 1
    This option is unfortunately hidden for many laptop users; the funny bit is that the laptop installer has a screenshot of the option; this screenshot is shown during installation. However, it cannot be reached after installation. – aggregate1166877 Dec 17 '16 at 7:24

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.