-1

Despite modifying all the display settings (brightness, contrast, sharpness, gamma, color temperature etc.) of my BenQ XL2730Z, I can't seem to get an acceptable contrast, especially with grey colors. Here's a photo of my Macbook display from Google Maps:

Google Maps on Macbook display

And here's the same photo on the BenQ display:

Google Maps on BenQ display

As you can see, on the Macbook display, the roads appear fine (the contrast between the white of the roads and the grey of the non-roads is acceptable). However, on the BenQ display, it's like there's no contrast at all.

This happens in several other web applications (including Gmail) rendering the LCD display almost unusable.

  • It's the display profile that's wrong. You could try a manual setup from system prefs > displays > color > calibrate... but these are usually less than satisfactory. The only real way to do it is with a hardware colorimeter. – Tetsujin Oct 29 '16 at 9:47
  • how is it that the default/out-of-the-box profile for such an expensive gaming monitor is so bad? I tried using the OSX calibration wizard but as you said, the results were even worse than the photos above. – faridghar Oct 29 '16 at 15:39
  • what's interesting is that when I enable f.lux and wait until night time, which is when f.lux kicks in, things get significantly better! – faridghar Oct 29 '16 at 15:39
  • You didn't mention f.lux... which will change the display profile itself. Best way to not have to fight f.lux at all is to not have it. btw, out of the box profiles can be a bit generic; a colorimeter is the only real way to get it right, trying to do it manually is very hit & miss, human eyes are just too forgiving. – Tetsujin Oct 29 '16 at 15:43
  • All the tests I did were with f.lux completely disabled. BenQ support just sent me a video where they navigate to Menu > Display > HDMI RGB PC range and switch its value to "RGB(0-255)". The thing is, on my monitor, this setting is greyed out and I cannot selected it. The only difference between my setup and BenQ support's setup is that I'm using a Macbook whereas they're using a Windows laptop. Could that be why? – faridghar Oct 31 '16 at 18:30
1

It turns out there's a setting in the monitor Menu > Display > HDMI RGB PC Range. You need to set this to "RGB(0 ~255)". If you have a Mac connected to the monitor, there's a chance that this setting will be greyed out and you won't be able to select it. If that's the case, follow the instructions here to enable the setting.

-1

and it could just be the display is getting old. My Samsung did a similar thing late in life. I forget what type screen that was, but newer displays don't seem to get old that way. If you can't reset to default and get a decent screen with tweaks in contrast and brightness, it may be time to visit smile.amazon.com

  • I just bought the display 3 weeks ago – faridghar Oct 31 '16 at 18:24

Your Answer

By clicking "Post Your Answer", you acknowledge that you have read our updated terms of service, privacy policy and cookie policy, and that your continued use of the website is subject to these policies.

Not the answer you're looking for? Browse other questions tagged or ask your own question.