5

Before, to change network connection priority under Windows I did: Network Adapters → Advanced Settings → Adapters and Bindings → Connections (there are several questions describing it on superuser)

After recent Windows 10 update (maybe earlier) there is no more "Adapters and Bindings" when I go to Advanced Settings. I have only provider order there!:

enter image description here

This window is what I see on several computers with windows 10 at hand now.

What is clicked wrong ? Where is Adapaters and Bindings ? And how to o change network connection priority now?

1
  • 3
    I'm going to guess that Microsoft decided few people cared, and took that feature out. Since they plan to convert all Control Panel items to the new Windows look, sparsely populated with few options and details, this is the pattern of all options, (IMO they are turning a great OS you can tweak into a "one size fits all".) Hunt around on W-10, 8, or 7, and you will likely find registry settings to change the priority of the adapters. Let me know if you find them and where.
    – DaaBoss
    Oct 29 '16 at 13:43
5

This legacy setting was superseded in Windows 10 with a new setting that is the "metric" much like in typical networking.

Go to your adapter properties, IPv4 settings, (keep current DHCP or static IP) and click on the "advanced button". There you will see the new checkbox automatic metric and the textbox to enter manually at your discretion. The lower the number the higher the priority.

Advanced TCPIP Settings

2

To complement JCMs correct answer, you can also configure the metric by using the PowerShell cmdlet Set-NetIPInterface (source, docs):

Set-NetIPInterface -InterfaceIndex <INDEX> -InterfaceMetric 100

This cmdlet is quite usefull, because it is the only way to adjust the metric of interfaces that you don't see in the GUI, like virtual interfaces.

Keep in mind, a high priority is equivalent to a low metric value.

1
  • Probably worth adding (just for copy and paste) that Get-NetIPInterface lists all of them. Nov 11 at 3:58

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.