0

How can I run 32-bit Debian (modified by ArchiveTeam) on Virtualbox if the CPU doesn't support VT-x?

I'm getting an error when starting virtual machine on VirtualBox, I also tried it on VMWare player, but didn't work.

VirtualBox Error message:

VT-x is not available. (VERR_VMX_NO_VMX)

VMWare error message:

The import failed because D:\archiveteam-warrior-v2-20121008.ova did not pass OVF specification conformance or virtual hardware compliance checks.

Click Retry to relax OVF specification and virtual hardware compliance checks and try the import again, or click Cancel to cancel the import. If you retry the import, you might not be able to use the virtual machine in VMware Player.

Host Specifications:

  • Atom™ N2800 (2 core / 4 threads) 1.86 GHz+
  • 4 GB RAM
  • 64-bit Windows Server 2012 R2
3
  • 1
    What's your host OS? I've used VMplayer a lot more than VBox, but both have options to control the use of VT-x, though I've not specifically tried 32-bit Debian, nor have I tried an Atom host.
    – AFH
    Oct 29, 2016 at 19:11
  • Host OS: 64-bit Windows Server 2012 R2
    – Rudolph
    Oct 29, 2016 at 19:31
  • 1
    Can't you select a CPU option which excludes use of VT-x in either VBox or VMplayer?
    – AFH
    Oct 30, 2016 at 0:32

1 Answer 1

2

No x86 hypervisors need VT-x to run a 32-bit guest. Only 64-bit guests need a type of virtualization for memory protection.

Generally the virtualization type is selected automatically and hardware virtualization will be used if available, otherwise it'll use software. However in this case your OVA file has set its own option, making the import of the file failed. You need to disable VT-x usage in the options. It'll be in acceleration tab in Virtualbox. Change Paravirtualization Interface to default then disable VT-x/AMD-v and nested paging

virtualbox acceleration

vbox old acceleration tab

In VMWare there's a similar option. Just change the Prefered mode to automatic and disable the two virtualize options below

vmware vt

And there'll always be an emulator option like qemu or bochs. This way you can run any architectures on your computer.

The initial version of x86-64 (AMD64) did not allow for a software-only full virtualization due to the lack of segmentation support in long mode, which made the protection of the hypervisor's memory impossible, in particular, the protection of the trap handler that runs in the guest kernel address space.[11][12]:11 and 20 Revision D and later 64-bit AMD processors (as a rule of thumb, those manufactured in 90 nm or less) added basic support for segmentation in long mode, making it possible to run 64-bit guests in 64-bit hosts via binary translation. Intel did not add segmentation support to its x86-64 implementation (Intel 64), making 64-bit software-only virtualization impossible on Intel CPUs, but Intel VT-x support makes 64-bit hardware assisted virtualization possible on the Intel platform.

https://en.wikipedia.org/wiki/X86_virtualization

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .