5

On my home's local network, I have a computer that hosts a VM server using VMware Workstation. Sometimes, my dad needs to use a virtual machine, but since his computer is not powerful enough to handle hosting a VM, I set up his computer with VMware Workstation so that he could connect to mine and use it as the host. This worked fine until today when I upgraded both his computer and mine from VMware Workstation 12.5 to VMware Workstation 12.5.1. Now, whenever he attempts to connect to the virtual machine's display after starting it, VMware freezes for several seconds before displaying an error message stating that VMware is, "Unable to connect to the MKS: Login (username/password) incorrect."

Whenever I first set this configuration up, I had this issue, and resolved it by allow incoming traffic on TCP ports 902 and 903 on the hosting machine as was suggested on this webpage. After the upgrade, the exceptions that I added to my firewall seemed to have been removed, so I added them back, and restarted both computers. Even after this, however, the problem is still occurring.

I went as far as doing a complete uninstall and reinstall of VMware on my dad's computer, using Revo to remove leftover files, but even this did not resolve the issue.

Does anyone have any idea what could be the problem? One thing that is worth noting is that I tried using telnet to determine if my dad's computer could "see" ports 902 and 903. The connection to port 902 worked just fine, but an attempt at connecting to 903 failed. This also happened whenever I tried to telnet to ports 902 and 903 on the host machine. I do not know if the issue with port 903 not connecting existed before because when I first set this up, I did not have the need to check the ports with telnet.

Update: I ran into this problem again when updating from VMware Workstation 12.5.1 to VMware Workstation 12.5.2. I was still able to fix the problem using the accepted answer.

  • 1
    For me this issue was caused by a DNS issue. My desktop running VMware workstation could not resolve the hostname of the ESXi server that vsphere told it to connect to. – Daniel S. Sterling May 3 '19 at 21:52
3

Since this question did not receive a response on Super User, I decided to post about it on the VMware forums. I received a response from a user by the name of "Tonyw23" that stated the following:

Thanks for using Workstation. This is an issue we are tracking internally. There is an easy fix you can have a try:

Go to both your WS server and your dad's machine, check config.ini under: C:\ProgramData\VMware\VMware Workstation Change the authd client port number from 903 to 902. e.g. authd.client.port = "902"
Then reboot both machines and have a try.

Original Forum Post

|improve this answer|||||

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.