After installing virtualbox-guest-dkms via aptitude, my Debian virtulabox is entirely unusuable now. Any attempt to boot it results in being stuck on a screen which cannot be interacted with in any way. Prior to this, it had gone from being stuck on a 1024 x 768 resolution to a 640-480 resolution. The process up until this point:

1) Configured the VM, which was stuck on 1024 x 768.

2) Went through the process described in the OP here.

3) I applied the steps mentioned in the reply up to step 3, but I looked up step 4 and couldn't find anything confirming what that suggestion would do and I was a bit suspicious of the brand new account.

4) Restarted my machine and tried to change the resolution to no avail, tried again to download the virtualbox-guest-dkms via aptitude, failed. Resigned myself to just using 1024 x 768. This was the state of things the last time I touched the VM on Friday night.

5) Now, I fire it up today and it's stuck in 640 x 480 resolution, but when I try again to pull down guest dkms via aptitude, it works. Again bear in mind, I'd already fully shut down the VM and restarted it multiple times between enacting the suggestions from that previous thread and now and the resolution had not changed, it only happened today, having not done anything to it since.

6) After pulling down guest-dkms, I rebooted the VM and now it's stuck like this whenever I try to boot to desktop.

enter image description here

1 Answer 1


I've resolved the issue.

Step 1) Log in to recovery mode by selecting the 'Advanced Options' item when you reach the first GUI login prompt 2) Run the following:

sudo apt-get remove virtualbox-guest-dkms

3) Restart the virtual machine.

Oddly enough, doing this allowed me to use 1920 x 1080p resolution, even though before I installed the dkms, I was stuck at lesser resolutions. The installation and uninstallation of the guest dkms is literally the only change I've made.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.