0

On my computer, I am currently unable to run any games that require use of the graphics card. I have done some basic troubleshooting and have traced the problem down to some sort of problem with openGL. The problem started yesterday when Minecraft crashed (the screen went black and non-responsive, and I had to end it with task manager), since then non of the games I have tried to run have opened, or have given an error (see below). I have tried updating the graphics driver (both from the AMD website, and from the device manager), restarted my computer many times, and uninstalled the driver for the graphics card multiple times. Any help with this would be greatly appreciated.

Computer specs:

-Operating System: Windows 10 Home 64 bit
-Display Adapters:
     AMD Radeom HD 8550G
     AMD Radeon R9 M275X (This is the one causing the error, and usually has a yellow exclamation mark next to it in the device manger)
-Processor: AMD A8-5557M APU with Radeon(tm) HD Graphics (quad-core) (2.10 GHz)
-RAM: 8.00GB (7.19Gb usable)

Monitor specs:

-Number of monitors: 1
-Model: BenQ GL2250H
-Connection to computer: HDMI
-Resolution: 1920 x 1080

Error 1 (No Man's sky):

A dialog box appears a few seconds after trying to start the game, titled 'Error', with the text "Unable to initialise OpenGL window"

Error 1

Error 2 (Minecraft):

After pressing "Play" on the launcher (set to any version) the launcher closes for a couple of seconds, then opens again with an error:

Minecraft Error The main part of the above image that I saw is:

OpenGL: ~~ERROR~~ RuntimeException: No OpenGL context found in the current thread.

Thanks in advance for any help.

BTW: I didn't know what information would be needed, so I just put whatever I could find that seemed relevant.

EDIT: I forgot to mention that the games that don't crash run extremely slowly (e.g: Elite: Dangerous - ~3fps)

  • 1
    Your system is attempting to use the APU instead of the dedicated GPU. The GPU built into your APU supports a different version of OpenGL than your GPU. – Ramhound Oct 30 '16 at 22:33
  • @Ramhound Thanks for the information. Do you have any tips on how to fix this? – sonrad10 Oct 31 '16 at 7:02
  • update GPU drivers and inside catalyst driver configure the game to run at high performance to use the GPU, not APU. – magicandre1981 Oct 31 '16 at 8:05
  • @magicandre1981 Thanks, I'll try this, and post my results here. – sonrad10 Oct 31 '16 at 18:41
  • I've reinstalled the AMD catalyst control panel, ans fiddled with the settings a bit, and it seems to be working now. Thanks for the help. – sonrad10 Oct 31 '16 at 19:28
1

Update the AMD GPU drivers, next you have to run the AMD Catalyst settings tool, go to the switchable Graphic Application settings, click on "Add application" and select the exe of the game and set it to high performance.

enter image description here

This configures the driver to use your AMD R9 M275X instead of the AMD APU.

Now download the tool call OpenHardwareMonitor and add the AMD R9 M275X settings to the Gadget. if the GPU is not used you see this:

enter image description here
(look at the - at GPU Clock, Speed)

If the GPU is used you see this:

enter image description here
(here you see the speeds, the V disaply and the temperature and this means the AMD GPU is now used)

If the GPU is used, it should support all required OpenGL calls, while the APU may miss some functions.

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.