6

After I did the Windows 10 Anniversary update 1607 (Dutch, so no Cortana), my search bar in start menu stopped working.

When I click the start menu and start typing something, it either closes immediately or it freezes and stops the whole explorer.exe. If I manage to get some text in the search box it does not search, but closes again.

I tried chkdsk C: /f and sfc /scannow but it didn't find any problems. However I haven't tried to boot in safe mode yet to see if it works, but I wonder if someone knows the problem and potentially has a fix for it.


Update 1: I tried it in safe mode, but also there it does not work. Same behavior. I open it and it closes immediately.

(IT'S BACK TO FORCE CLOSING) Update 2: I tried the powershell commands provided by the link @Dave posted. My search bar isn't force closing now, but when I type the screen is blank. Image of the current status: search with the command "search" but blank results.

NOTE: 'search' is the term I typed in to try.

Update 3: Event viewer logs error:

Naam van toepassing met fout: SearchUI.exe, versie: 10.0.14393.351, tijdstempel: 0x5801a548 Naam van module met fout: SearchUI.exe, versie: 10.0.14393.351, tijdstempel: 0x5801a548 Uitzonderingscode: 0x80000003 Foutmarge: 0x00000000001f688f Id van proces met fout: 0x1d9c Starttijd van toepassing met fout: 0x01d23461791f2ca6 Pad naar toepassing met fout: C:\Windows\SystemApps\Microsoft.Windows.Cortana_cw5n1h2txyewy\SearchUI.exe Pad naar module met fout: C:\Windows\SystemApps\Microsoft.Windows.Cortana_cw5n1h2txyewy\SearchUI.exe Rapport-id: 9145fff4-6be1-4ed2-8ab4-a9c8d1ccb850 Volledige pakketnaam met fout: Microsoft.Windows.Cortana_1.7.0.14393_neutral_neutral_cw5n1h2txyewy Relatieve toepassings-id van pakket met fout: CortanaUI

  • @Dave It didn't find any problems or corrupt files. So I lost it there. I will try safe mode when I'm home, but I thought maybe someone know's a problem right away. I could update the post when I tried. – Kees Sonnema Oct 31 '16 at 8:41
  • @Dave I tried safe mode. Still the same. Search does not work at all. – Kees Sonnema Oct 31 '16 at 16:34
  • @Dave Updated the op – Kees Sonnema Oct 31 '16 at 20:11
  • Is there anything in event viewer. Did you try to rebuild the index. Does the issue occur when you click start menu and press windows key on your keyboard? – Dave Oct 31 '16 at 21:36
  • 1
    ok, I've submitted the dmp to Microsoft. I hope I get a reply in the next days. – magicandre1981 Nov 6 '16 at 6:37
4
+200

I'm not sure if Cortana is installed your system or not. But I'm certainly sure that Cortana is a MAIN part of Windows Search, and in SOME of Windows 10 editions Cortana is Disabled by default. Meaning it's installed on the system, but its functionality is DISABLED. If something happened to Cortana files, then the WHOLE search system will be affected as well. Same thing happens in reverse.

So, what you actually need to do, is to reinstall Cortana from the Local Machine and not from the current user. The link that @Dave gave you is a one step but it will give an error (AS you experienced). Anyhow, I will give you the steps that I did in order to solve this issue.

  1. Go to Services and disable + Stop Windows Search. (Then Save your settings).
  2. Go to Powershell (Right-Click and open as administrator).
  3. Type Set-ExecutionPolicy Unrestricted then hit enter.
  4. Next, Type Get-AppXPackage -AllUsers | Foreach {Add-AppxPackage -DisableDevelopmentMode -Register "$($_.InstallLocation)\AppXManifest.xml"}
  5. Now, go back to Services and re-enable Windows Search, Change Startup to (Automatically Delayed Start) and click on Start.
  6. Restart your system.

If you still experience problems, (press windows key + R) then type wsreset.exe, and follow the wizard. This should reset Windows Store cache (Yes, Windows Store affects all Windows built-in apps including Start menu functionality).

Method 2:

Open the command prompt as administrator, then Type:

DISM.exe /Online /Cleanup-image /Scanhealth

then hit enter.

Wait until it's finished then type:

DISM.exe /Online /Cleanup-image /Restorehealth

then hit enter. Wait until it's finished.

After it's done, go to Services and check Windows Search service, it should be Started / Automatic (Delayed Start)

Restart your system and check.

Method 3 (Best Answer):

After the file is downloaded, Uncompress it then run Repair_Windows.exe as administrator to avoid any permission issues. Then follow the following steps:

From Tweaking.com's Repair Tool window do the following:

  • Go to Repairs tab
  • Click on Open Repairs
  • Untick first option (parent option) to untick all its options.
  • Now, tick the following options:
    • 27 Set Windows Services To Default Startup
    • 28.02 Repair Windows 8/10 App Store (Completely Reset App Store)
  • Then, click Start Repairs, and the tool will do the rest of the work.

When it's done, make sure to restart your machine.

| improve this answer | |
  • I will try this first and if this does not work I will update windows 10 to itself as @harrymc said – Kees Sonnema Nov 4 '16 at 20:48
  • I've got an error when executing Set-ExecutionPolicy Unrestricted hastebin.com/ohujowuven.sql – Kees Sonnema Nov 4 '16 at 20:59
  • @KeesSonnema this is not an error, it's a success confirmation of the command execution. – iSR5 Nov 5 '16 at 0:12
  • 1
    @KeesSonnema best option I see is to try creating a new account, and check if it has the same issue. If not, try to use Tweaking.com's Windows Repair tools (download the portable version) over this link: tweaking.com/content/page/windows_repair_all_in_one.html – iSR5 Nov 8 '16 at 21:55
  • 1
    @iSR5 if you update your question to specify what steps specifically you took to solve the problem I will award you a 150 reputation bounty. – Ramhound Apr 13 '17 at 22:58
0

If you have tried the troubleshooting then change the Search settings in Windows 10 to enable search

Change Search Index Settings in Windows 10

  • Press the window key + R button to open run command
  • Type the command %LocalAppData%\Packages\windows.immersivecontrolpanel_cw5n1h2txyewy\LocalState

    Press Enter or click OK

  • A new window will open with Indexed folder
  • Right click on the indexed folder and select properties
  • Click on Advanced button in the dialog box open
  • Checkmark the option ‘Allow files in this folder to have contents indexed in addition of file properties’
  • Click OK and then Apply
  • The progress bar will appear completing the indexing
  • Click on OK when the indexing is completed

Now restart the device and search items, Window OS will show related items.

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.