1

My duplicity command looks like

sudo duplicity --tempdir /media/scratch/tmp --no-encryption --archive-dir /media/scratch/duplicity --exclude /media/nas/backup --exclude /proc --exclude /sys --exclude /media/scratch/duplicity --exclude /media/scratch/tmp /  file:///media/nas/backup

But although I specified a directory on my second SSD with --archive-dir, duplicity keeps filling up my main SSD at ~/.cache/duplicity. According to the manpage:

--archive-dir path The archive directory. NOTE: This option changed in 0.6.0. The archive directory is now necessary in order to manage persistence for current and future enhancements. As such, this option is now used only to change the location of the archive directory. The archive directory should not be deleted, or duplicity will have to recreate it from the remote repository (which may require decrypting the backup contents).

When backing up or restoring, this option specifies that the local archive directory is to be created in path. If the archive directory is not specified, the default will be to create the archive directory in ~/.cache/duplicity/.

What am I missing here?

0
4

Instead of:

--archive-dir /media/scratch/duplicity

Try:

--archive-dir=/media/scratch/duplicity

Notice the "=" sign. This worked for me.

0

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.