3

I use OneDrive for Business to sync document libraries from sharepoint to my local disk.

All libraries are synced to C:\Users\myusername\Sharepoint

Within this directory the libraries get a new directory each, whose name is a moronic concoction from the subsite name and the document library which I cannot influence. It is moronic because it contains spaces and special characters like dashes and commata. I have several software applications running which fail to operate on paths with spaces and commas inside. OneDrive doesn't even use the URL-Path of the SP-subsites (which I could understand) but rather the description, which drives me crazy.

This is ironic as sharepoint and onedrive themselves prevent most special characters in file and folder names.

I tried nearly everything from renaming the folders in explorer to searching regedit for the storage of the folder settings.

How can I effectively change the folder names on my harddrive?

addendum: Windows 7 Enterprise, SP1 Groove.exe: 15.0.4859.1000

1

I did some research on this topic and managed to find out something about the ominous groove.exe.

  • The names of the local onedrive folders are not held in the registry
  • Renaming the Folders from within explorer does change only the appearance in explorer, the Folder will stick to its old name when viewed in cmd.exe or when the path is copied or opened by any third party software, still containing the dirty characters
  • All information about the folders and the destinations where they seem to point to reside deep in C:\Users\"user"\AppData\Local\Microsoft\Office\Spw
  • groove.exe seems to encrypt or mangle its data, so you cannot edit the configuration files (which seem to end with .xss) by using a normal editor like vim.
  • Naming of the local folders possibly can be governed by policies
  • Installing a .lnk file does not help, as many programs can't resolve it.

I then resorted to a workaround I like to describe here:

I made a symbolic link pointing to the sync directory but containing only normal characters, by typing mklink /D . This was only possible inside a cmd.exe with administrative rights. The outcome was enough to fool my software into using the directory without wrecking the path.

| improve this answer | |
1

As you state in the issue description you can not change how the synced folder is named on your client. It is based on the SharePoint Title and the Document Library Title. To change it you have to edit these properties in the SharePoint settings. I don't know any other way.

Related nice resource

| improve this answer | |

Your Answer

By clicking “Post Your Answer”, you agree to our terms of service, privacy policy and cookie policy

Not the answer you're looking for? Browse other questions tagged or ask your own question.